[quake2] Quake2 GL Problems [partly solved]

Gian Paolo Mureddu thetargos at tutopia.com
Sun Nov 23 01:48:50 EST 2003

Matthew Goins wrote:

>I managed to partly fix the problem by adding:
>SubSection  "extmod"
>  Option    "xfree86-dga"
>  EndSubSection
>to my /etc/X11/XF86config file.
>Now the only problem is that when I run quake2-qmax under glx, I don't
>get any sound. The only way sound works is if I use sdlquake2-qmax. Not
>a big deal, just a minor annoyance. 
To me DGA was no go, it wouldn't do anything but keeping me from going 
to fullscreen. Plus I've found some new annoyances:

    * In order to play the movies in the game (or to change Missions) I
      have to switch from SDLGL to GLX.
    * To get back my mouse control I have to again switch.

Matt, did do you actually have another executable labled quake2-qmax? I 
built qmax support according to the ReadMe file and disabled AAlib (got  
some compilation errors). However I think I'm using the MAX extensions 
(so to speak) cause I get decals, see this screenie (sorry for the 
inconvinience if someone uses a text-only mail reader):

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://icculus.org/pipermail/quake2/attachments/20031123/b041c6bc/attachment.htm>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: quake01.jpg
Type: image/jpeg
Size: 124211 bytes
Desc: not available
URL: <http://icculus.org/pipermail/quake2/attachments/20031123/b041c6bc/attachment.jpg>

More information about the quake2 mailing list