[quake2] Quake2 GL Problems [partly solved]

Matthew Goins arkestra at tds.net
Sat Nov 22 22:40:11 EST 2003

I managed to partly fix the problem by adding:

SubSection  "extmod"
  Option    "xfree86-dga"

to my /etc/X11/XF86config file.

Now the only problem is that when I run quake2-qmax under glx, I don't
get any sound. The only way sound works is if I use sdlquake2-qmax. Not
a big deal, just a minor annoyance. 


On Thu, 2003-11-20 at 21:48, Matthew Goins wrote:
> Sorry to bug people, but I think I am missing something obvious on this
> one.
> I am running the relnev version of quake2 under Gentoo Linux. The game
> runs perfectly under vid_ref softx, however, under vid_ref glx I get a
> strange box of garble in the right-bottom corner of the screen, and the
> mouse is very jerky and impossible to use. Has anyone seen this problem?
> I have run the game under different linux distros, so I fear I just
> failed to set something up correctly.  More info: I am using the
> standard, latest nvidia drivers on a geforce 4 card. Other games seem to
> run under GL (tuxracer for example).
> I have already made sure that GPM or other mouse-using stuff is
> disabled, and I  really don't know where to turn but this list, as other
> forums haven't responded. Thanks in advance!
> Matt

More information about the quake2 mailing list