[openbox] [ANNOUNCE] Openbox-3.0-rc3 released

Ben Jansens ben at orodu.net
Thu Oct 9 23:21:18 EDT 2003

On Thu, Oct 09, 2003 at 05:38:38PM -0500, Mike wrote:
> Hm, anyone losing windows when openbox is restarted? I run rxvt, then Menu 
> -> Restart, and it's gone.
> My console shows some segfaults, one specifically with an assertion failed 
> on 'hash_table != NULL', happened after doing a few restarts in a row 
> (while trying to figure out why windows are disappearing). The majorty give 
> no explanation.
> Unfortunately, I run with ulimit -c 0. I cannot exit X at the moment, so I 
> can fix that for consistent coredumps.
> Fortunately I use a function in my ~/.xinitrc to start up the window 
> manager (in case it crashes), so it restarts in 5 seconds. The 5 second 
> wait allowed me to restart openbox in a ulimit -c unlimited term and get a 
> core, which coincidentally disappeared when it started back up, so I'm back 
> to my restart function. :P
> (gdb) bt
> #0  0x403da641 in kill () from /lib/libc.so.6
> #1  0x4023b4d1 in pthread_kill () from /lib/libpthread.so.0
> #2  0x4023b7db in raise () from /lib/libpthread.so.0
> #3  0x403da3f4 in raise () from /lib/libc.so.6
> #4  0x403db95b in abort () from /lib/libc.so.6
> #5  0x08061d1e in sighandler (sig=11) at openbox/mainloop.c:435
> #6  0x4023e695 in __pthread_sighandler () from /lib/libpthread.so.0
> #7  <signal handler called>
> #8  0x00000022 in ?? ()
> #9  0x400ed95a in g_hash_table_remove () from /usr/lib/libglib-2.0.so.0
> #10 0x402b76f8 in RrColorFree (c=0x8168f00) at render/color.c:91
> #11 0x402bd019 in RrAppearanceFree (a=0x80984f8) at render/render.c:253
> #12 0x402c0872 in RrThemeFree (theme=0x8097380) at render/theme.c:1075
> #13 0x08065e6f in main (argc=1, argv=0xbffffaa4) at openbox/openbox.c:292

You should read http://openbox.org/bugs.php and report this properly >:)

> I've also noticed the past two release, openbox seems to pause for upwards 
> of 5 or 10 seconds on *some* restarts. Which could be related to g_usleep() 
> calls in replace_wm().

Again, put it in the bugzilla please, with a reliable method to cause it.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
URL: <http://icculus.org/pipermail/openbox/attachments/20031009/49b64297/attachment.pgp>

More information about the openbox mailing list