[lokisetup] [PATCH]<<3 suffix and productdir attributes, zip fixes, ui changes

Ludwig Nussel ludwig.nussel at gmx.de
Tue Nov 2 15:24:59 EST 2004

Stephane Peter wrote:
> OK, I just committed most of these patches, to the exception of the  
> binary inline script patches.
> The reason I haven't merged them yet is that I want to make some slight  
> changes to them, especially I'd like to change the name of the tmpdir()  
> function that you added. It may conflict with some other libraries...

Thanks, should be easy to add a prefix.

> On Oct 31, 2004, at 5:53 AM, Ludwig Nussel wrote:
> > [...]
> >loki_setupdb-closeproduct.diff
> >	- save xml to a temporary file and then atomically rename it
> >	  to prevent corruption if loki-setup crashes while writing
> >	  the file. Yeah, that crash which corrupted my ut2004 xml
> >	  file was my own fault but still this patch makes things
> >	  more robust :-)

I just noticed that this will cause error messages upon uninstall.
They didn't show up before as errors where ignored previously.


(o_  Ludwig.Nussel at gmx.de
V_/_ PGP Key ID: FF8135CE

More information about the Lokisetup mailing list