[cod] Patch 1.2 requires glibc 2.3 OMG!!!

Ryan C. Gordon icculus at clutteredmind.org
Fri Jan 30 15:53:07 EST 2004

On Fri, 2004-01-30 at 08:06, Steven Hartland wrote:
> This is NOT good so not good there are mucho
> incompatibilities between 2.2 and 2.3 using 2.3 is just not
> an option :(
> Been though this with a few game fortunately been on
> the beta programs and caught it before it was released.

We're not linked against glibc 2.3. There isn't even a copy of 2.3 on
the system where this game is built.

We're linked against some support libraries gcc3 requires. Specifically,
libgcc_s.so.1 and libstdc++.so.5.

There's an exploitable DoS in the 1.1 server due to buggy codegen in gcc
2.95.3, so we had to move up to gcc3. It's possible the Behind Enemy
Lines bug in 1.1 is also caused by bad codegen.

FreeBSD users get these libraries in linux_base-8. 

This is NOT glibc 2.3!


More information about the Cod mailing list