[cod] Patch 1.2 requires glibc 2.3 OMG!!!

Daniel Rudolph lists at daniel-rudolph.de
Fri Jan 30 16:19:27 EST 2004

Ryan C. Gordon wrote:

> We're not linked against glibc 2.3. There isn't even a copy of 2.3 on
> the system where this game is built.
> We're linked against some support libraries gcc3 requires. Specifically,
> libgcc_s.so.1 and libstdc++.so.5.
> There's an exploitable DoS in the 1.1 server due to buggy codegen in gcc
> 2.95.3, so we had to move up to gcc3. It's possible the Behind Enemy
> Lines bug in 1.1 is also caused by bad codegen.
> FreeBSD users get these libraries in linux_base-8. 
> This is NOT glibc 2.3!
If i install that lib in debian i have a slight problem.
The libstdc++5 is only in unstable.

Maybe thats a problem of the debian depencies but im not going to force 
them manually ;-)

 >apt-get -t unstable install libstdc++5
Reading Package Lists... Done
Building Dependency Tree... Done
The following extra packages will be installed:
   gcc-3.3-base libc6 libc6-dev libdb1-compat libgcc1 linux-kernel-headers
The following NEW packages will be installed:
   gcc-3.3-base libdb1-compat libstdc++5 linux-kernel-headers
3 packages upgraded, 4 newly installed, 0 to remove and 129  not upgraded.
Need to get 9317kB of archives. After unpacking 8335kB will be used.
Do you want to continue? [Y/n]
Get:1 http://ftp.de.debian.org testing/main libdb1-compat 2.1.3-7 [30.8kB]
Get:2 http://ftp.de.debian.org unstable/main libc6-dev 2.3.2.ds1-11 [2530kB]
Get:3 http://ftp.de.debian.org unstable/main linux-kernel-headers 
bk-15 [1377kB]
Get:4 http://ftp.de.debian.org unstable/main libc6 2.3.2.ds1-11 [4878kB]
Get:5 http://ftp.de.debian.org unstable/main gcc-3.3-base 1:3.3.3-0pre3 
Get:6 http://ftp.de.debian.org unstable/main libgcc1 1:3.3.3-0pre3 [73.3kB]
Get:7 http://ftp.de.debian.org unstable/main libstdc++5 1:3.3.3-0pre3 

> --ryan.
Thx for details

More information about the Cod mailing list