[bf1942] V1.01 Mods work?

Steven Hartland killing at multiplay.co.uk
Tue May 25 15:38:44 EDT 2004

Ah indeed I'd left a default map list in there. Still using the old
+game <mod> syntax on the command line what a Muppet :P

Below is the stack trace:
#0  0x088f4596 in dice::ref2::geom::GrowthManager::init() ()
(gdb) bt
#0  0x088f4596 in dice::ref2::geom::GrowthManager::init() ()
#1  0x086b4e54 in dice::bf::Game::load(std::string const&, std::string const&, std::string const&) ()
#2  0x0872d210 in dice::bf::GameServer::load() ()
#3  0x0872ef82 in dice::bf::GameServer::startServer(std::string const&, int, std::string const&, int) ()
#4  0x086d5807 in dice::bf::Setup::startHostGame(std::string const&, int, int, int, float, float, float, float, float, int, int,
std::string, bool) ()
#5  0x086ccfc1 in dice::bf::Setup::initWorld() ()
#6  0x086c9db8 in dice::bf::Setup::start(std::string const&) ()
#7  0x0804e894 in main ()
#8  0x18b8714f in ?? ()

Interesting so I ran it under windows and got:
Battlefield Vietnam Dedicated Server v1.01
"VADER"                                  Map:
IP:  Port: 15567                         Mod: TourOfDuty   Map mod: TourOfDuty
PunkBuster: off   XML log: disabled      Players: 0/32     CONQUEST
                                         Round: 1/3 ( 0:42 / 0:00 )
FPS: 60/60   [16 : 17]                   RED 200, BLUE 193
OS: 0 SK 0 Util%:  1.3                   [playing]

Note: No map???
And when u look in maplist.con you get:
game.setCurrentLevel  GPM_CQ

This was starting it via the little DS GUI.

But I then added the maps like u did manually and it also crashed.

So did some digging and tried:
game.addLevel hamburgerhill GPM_CQ tod
game.addLevel river_raid GPM_CQ tod
game.setCurrentLevel hamburgerhill GPM_CQ tod

This works fine on both so I suspect ur crashes are all due to:
"I cant find that map / map + mod"
Running a truss on the process shows:
ERR#2 'No such file or directory'

So all it all looks ok, all be it doesn't deal with missing maps very
well at all no either platform and the GUI doesn't work with mods.

N.B. Even with this correct maplist.con the server still doesn't
appear in the list when the mod is selected. You have to select
BFV. But GameID does show as "tod" and the console looks like:
Battlefield Vietnam Dedicated Server v1.01
"Multiplay.co.uk:: Test Server"          Map: river_raid
IP: Port: 15567                  Mod: tod          Map mod: TourOfDuty
PunkBuster: on    XML log: disabled      Players: 0/32     CONQUEST
                                         Round: 1/2 ( 2:38 / 0:00 )
FPS: 50/60   [19 : 20]                   RED 200, BLUE 200
OS: 1 SK 0 Util%:  0.5                   [playing]

Hope this helps.

    Steve / K

----- Original Message ----- 
From: <sjdel at nycap.rr.com>
To: <bf1942 at icculus.org>
Sent: Tuesday, May 25, 2004 7:37 PM
Subject: Re: [bf1942] V1.01 Mods work?

> Unfortunately not, I've tried on 2, make that 3, perfectly functioning bfv servers on linux boxes, 2 using RH9, and one on RH
Ent 3.0 :(
> Only thing I've really done was change the case using fixinstall.sh and make changes to maplist.con reflecting a small subset of
the tod maps:
> game.addLevel hamburger_hill GPM_CQ tod
> game.addLevel hamburger_hill_one GPM_CQ tod
> game.setCurrentLevel hamburger_hill GPM_CQ tod
> After it crashed initially, I even checked the init.con to see if the case issues in that were effecting startup, but it made no

This e.mail is private and confidential between Multiplay (UK) Ltd. and the person or entity to whom it is addressed. In the event of misdirection, the recipient is prohibited from using, copying, printing or otherwise disseminating it or any information contained in it. 

In the event of misdirection, illegible or incomplete transmission please telephone (023) 8024 3137
or return the E.mail to postmaster at multiplay.co.uk.

More information about the Bf1942 mailing list