AW: [bf1942] chown on start?

Reinder P. Gerritsen reinder at
Fri Jul 4 06:32:22 EDT 2003

If it were a root process that tried to write to the file... It would
without trouble have done so. (there was no immutable flags on the

It was running in the backgroud als it's own user. Wat exactly happened
I could not trace back. Fact was: the box froze completely at mapchange
where it previously did not. 
Difference was a change of filerights of the config files. (since I
copied another config to the location after I editted as root.

Aparently, a mall programmed UT Server (and I believe strongly this
linux server wasn't exactly great programming. It seemed quite unstable
to me) could bring down the system in running in user-land.

-----Original Message-----
From: ScratchMonkey [mailto:ScratchMonkey at] 
Sent: Friday, July 04, 2003 09:23
To: bf1942 at
Subject: RE: AW: [bf1942] chown on start?

--On Friday, July 04, 2003 8:23 AM +0200 "Reinder P. Gerritsen" 
<reinder at> wrote:

> Tried that in Unreal Tournament once. The result was I had to drive 
> back to the colocation some 60 km away, because not being able to 
> write to config caused UT to K.O. my box. Was realy happy about that 
> at 11 pm.
> ;-)

How would a userland process freeze the box? Or were you running it as 
root? Which I would think not because otherwise what would be the whole 
point of chowning the config?

More information about the Bf1942 mailing list