[quake2] Icculus Q2 (Gentoo build), mods won't work

Lee Webb lee.webb at dot.net.au
Wed Sep 1 19:00:18 EDT 2004

Hi All,

Many thanks for all the replies.

Built the source without using portage (no gentoo build) and the mods
worked correctly, so the there must be something wrong with the way
portage does the build, I'll look more into this today instead of

The only problem I now get is some SIGSEGV when running in anything over
640x480 full screen with nvidia's liGL.so. Only happens when trying to
get the console or view the menus. When running 640x480 windowed
everything is fine.

Tracked it down to some calls to ld-linux.so.2, seems like either q2 or
the nvidia driver is doing something stupid

Will attach the stack trace when I get home

Lee Webb

Systems Administrator
Dot Communications
lee.webb at dot.net.au

On Thu, 2004-09-02 at 07:22, Nick Warne wrote:
> On Wednesday 01 September 2004 22:06, Steven Edwards wrote:
> > > Seriously there _must_ be something wrong with the way it is set up
> > > for it to
> > > not work.
> >
> > My money is on a over optimized gentoo build.
> Sorry, disagree again.
> An optimised built will not make the thing _not_ work as asked.  It will 
> crash, perhaps, or lock up... but it will initially work as it should.  On my 
> Xatrix server I run every Sunday for friends I built the server ded code with 
> Intels ICC and all the game stuff (i.e. monster code) taken out - but 
> whatever I start game with the server  works.  Same here on my quake2 client 
> Slackware 10.
> No, the problems here are definitely file hierarchy/and or/the way it is 
> started.  If it doesn't find pak files etc, then that is a set-up problem... 
> not code.
> Nick

More information about the quake2 mailing list