[quake2] help with q2lnx

Jack Coates jack at monkeynoodle.org
Wed Nov 5 07:17:50 EST 2003

On Wed, 2003-11-05 at 03:05, matthieu wrote:
> thanks guys for all these answers.
> Jack Coates wrote:
> > the // will be handled by the shell, no problem there.
> i think so
> > probably a problem, or other incompatibility in the config file. Here's
> > my setup:
> > [...]
> > set gl_driver "libGL.so"
> > 
> > note the gl driver name.
> i solved the problem by simlinking libGL.so.1 in my quake2 directory:
> $ls -alF /home/matthieu/prog/quake2/libGl.so.1
> lrwxrwxrwx    1 matthieu matthieu       19 Nov  4 17:49 libGL.so.1 ->
> /usr/lib/libGL.so.1*
> I also changed in ~/.quake2/baseq2
> set gl_driver "/usr/lib/libGL.so"
> to
> set gl_driver "libGL.so"
> and now i lauch with
> ./quake2 +set basedir /home/matthieu/prog/quake2 +set vid_ref glx
> (the +set basedir is a precaution since anyway i launch from this directory)
> so Quake2 launches ok and i can play.
> I had a problem with:
> Error: Missing Particle Picture: particles/beam.jpg
> but i solved it by installing the additional maxpack.pak
> i think that the segfault i described in my first mail is not due to the
> softx driver, but to the fact that i have changed the renderering driver
> without quiting quake, because i had also this segfault with the glx
> driver if i had launched in softx and later changed to glx. In my first
> tries, i launched in glx in it automatically switched to softx as it
> could't find glx, so it also caused the segfault.
> I have also the following litle bug: if is change any video parameter
> (resolution, texture pixel format, ...) with the glx driver, and apply
> the changes (apply button in the video menu) then, as soon as i press a
> key, quake shutsdown with the following message:
> Received signal 11, exiting...
> a few other questions:
> - with glx, even with brightness set at its maximum, the image is still
> really dark. Is there anything to do to improve that ?
> - where is the screen resolution saved ? Not in
> ~/.quake2/baseq2/config.cfg it seems
> - In you config.cfg, jack, you have some options that i don't have in
> mine. For example:
> set gl_particle_att_c "0.01"
> set gl_particle_att_b "0.0"
> set gl_particle_att_a "0.01"
> set gl_particle_size "40"
> set gl_particle_max_size "40"
> set gl_particle_min_size "2"
> set _windowed_mouse "1"
> i added these options in my config.cfg, but quake2 automatically removes
> all the particle stuff, while it keeps the _windowed_mouse. Could you
> explain me this behavior?

No idea... maybe the video card doesn't support those functions? I don't
have maxpack installed, and I usually play on a relatively anemic i810
laptop, but I copied that config from my voodoo3-equipped desktop.
Jack Coates
Monkeynoodle: A Scientific Venture...

More information about the quake2 mailing list