Quake2 and

Juan Francisco Rodriguez Hervella jrh at it.uc3m.es
Tue Oct 22 04:58:20 EDT 2002


I'm trying to install some server-side mods
to get some bots on my Quake2 server, but I've
tried with "Eraser" and "Lithium" (and more I don't
remember right now), but I haven't had any success.

I'm using a CVSuped version of Quake2 that supports
IPv6 (http://www.viagenie.qc.ca/en/ipv6/quake2/ipv6-quake2.shtml),
which compiles without problem in my FreeBSD-4.5

When I try to use "Eraser" or "Lithium", I usually obtain this

jrh at pulgon:/usr/home/jrh/.quake2$ ./quake2 +set dedicated 1 +set game
Quake 2 -- Version 3.21+rCVS
Added packfile ./baseq2/pak0.pak (1106 files)
using /home/jrh/.quake2/baseq2/ for writing
Added packfile /home/jrh/.quake2/baseq2/pak0.pak (1106 files)
using /home/jrh/.quake2/lithium/ for writing
execing default.cfg
execing config.cfg
------- Loading gamei386.so -------
LoadLibrary (/home/jrh/.quake2/lithium/gamei386.so): Undefined symbol
ERROR: failed to load game DLL
Error: Error during initialization           

Has anyone tried to do this before ?
I've been able to run "Eraser" and "Lithium" using a 
precompiled version of Quake2-3.20, but that version
doesn't support IPv6. What can I do ? I've been looking for
the source code of Quake2-3.20 but I've found nothing...


PD: As I've told you, I'm using FreeBSD-4.5 :)


More information about the quake2 mailing list