[quake2] Questions about Quake2 and Solaris :-)

Vincent Cojot coyote at step.polymtl.ca
Fri Jun 14 01:36:00 EDT 2002

Hello all,

	sorry that I missed the thread.. Hello Steve,.. Are you running
Solaris 8 later than 04/01.. (as in Solaris 8 07/01 10/01, 02/02 or an MU
later than MU4)? I have found that the old sound code does -not- work well
with recent versions of Solaris 8.. It complains about some invalid ioctls
(if I recall correctly).. I have new routines that work but they are not
in the 0.12 version yet. (changed jobs recently and it's hell on earth
at the new job).

	Also, if you have an Elite3D M4, it's still not enough to get
decent GLX performance.. You need an Expert3D (-NOT- the lite version)..
(that's what the SUN people said.. Since I only have an Ultra2 at 300Mhz with
a Creator3D, I have not been able to verify that statement).

	For the sound problem: instead of using "quake2", use "sdlquake2"
after you install SDL by yourself or from the "Software Companion CD" that
came with Solaris 8.. That will fix the sound problem.  I will work on
fixing the main binary ("quake2") next.. I hope this helps.. Do you want a
tarball of the complete set of Solaris8/sparc binaries? I have not made a
package yet.. should be in a couple weeks and this should make life -MUCH-
easier for people who want to install Quake2 under Solaris..

PS: Drop me a line if you find other problems, I'm (trying to)
maintain(ing) the Solaris part of the port... :)


On Thu, 13 Jun 2002, Steve wrote:

> Hey there :-)
> First of all, Quake 2 does NOT like my /dev/audio and there doesn't seem
> to be an obvious way to make Quake2 not play sound at all.  I went into
> source files and hacked the sound a bit so (hopefully) it won't do
> anything, but still this may be the root of my problems :-)  Is there any
> way to get Quake2 to just *not* play sound under Solaris, or maybe there
> should be a compile option?
> Secondly, it's pointlessly slow.  I'm running an Ultra60 dual 360Mhz with
> Elite3d M4 graphics; I'm not sure if my slowness is due to how I disabled
> the sound (... I'd think it would go faster, personally) or if it's just
> gonna suck in general.  It's only fast if I run in a tiiiiiny little
> window and even then it can be rather stuttery.  The machine is doing
> *nothing* else but Quake2 at the time.  I tried both softare and XIL mode,
> and I've got the latest install of Solaris 8.
> Any tips would be appreciated; especially on if it's possible to speed it
> up a bit.  Or, if it's just going to suck, at least I'll know for sure
> it's just me or not ;-)
> Thanks for your help!
> Steve

Vincent S. Cojot, Computer Engineering. STEP project. _.,-*~'`^`'~*-,._.,-*~
Ecole Polytechnique de Montreal, Comite Micro-Informatique. _.,-*~'`^`'~*-,.
Linux Xview/OpenLook resources page _.,-*~'`^`'~*-,._.,-*~'`^`'~*-,._.,-*~'
http://step.polymtl.ca/~coyote  _.,-*~'`^`'~*-,._ coyote at step.polymtl.ca

They cannot scare me with their empty spaces
Between stars - on stars where no human race is
I have it in me so much nearer home
To scare myself with my own desert places.       - Robert Frost

More information about the quake2 mailing list