[openbox] KeePass Autotype does not work, Failed to execute the child process

Aquarius aquarius at tutanota.de
Fri Jan 8 14:12:07 EST 2016

As per Ian's request I restart my issue. Here is a recap of the info gathered 
from previous post in the thread with title "Key binding can not find child 
process ...":
I am trying to get key bindings work for KeePass. I use 'keepass --autotype' 
for action.
I get a message "Failed to execute the child process „keepass“ (No such file 
ore directory).“
Tried a lot of things but nothing seems to help.
I run Debian Wheezy and latest version of KeePass.

In the lxde-rc.xml file in the <command> line I tried:
"/usr/lib/keepass2/KeePass.exe --autotype"
"/usr/bin/cli /usr/lib/keepass2/KeePass.exe --autotype"
"/usr/bin/keepass2 --auto-type"

/usr/bin/cli is a symbolic link which points ultimately to mono-sgen.
I tried "cli /usr/lib/keepass2/KeePass.exe" in a terminal and Keepass start 
up and I can login to the database.

I start KeePass with a line in 'autostart' and that works fine.

When using locate "*eepass*" I get amongst others:
/usr/bin/keepass2 executable script with line exec /usr/bin/cli 
/usr/lib/keepass2/KeePass.exe "$@"

When using 'echo $PATH':

When I do a "ps aux | grep eepass" I get:
/usr/bin/cli /usr/lib/keepass2/KeePass.exe

Securely sent with Tutanota. Claim your encrypted mailbox today!
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://icculus.org/pipermail/openbox/attachments/20160108/ee3c6093/attachment.html>

More information about the openbox mailing list