[openbox] set working directory when starting Openbox

Crni Gorac cgorac at gmail.com
Thu May 22 08:30:07 EDT 2014

What you described is somewhat opposite to what happens on my machine.
 I have Openbox 3.5.2, and xinit 1.3.3.  I have following snippet in
my $HOME/.bash_login:
cd /tmp

case $(tty) in
and my $HOME/.xinitrc is simply:
exec openbox-session

Now, when I login (on first tty), Openbox get started automatically,
and despite working directory being set to /tmp before xinit run,
Openbox is properly reading all files from $HOME/.config/openbox
directory.  However, when I run an xterm from within Openbox, the
working directory is set to $HOME (instead to /tmp).

I recently switched to Openbox from E17, and the setup described went
practically unchanged (except that instead of "exec openbox-sesssion"
I had "exec enlightenment_start" in my $HOME/.xinitrc file).  However,
when xterm run in E17, its working directory would be /tmp, as I would


On Thu, May 22, 2014 at 2:01 PM, Mathias Dufresne
<mathias.dufresne at gmail.com> wrote:
> Ok. I'm not an Openbox dev, nor even a dev at all, but for me this behaviour
> is not part of the window manager, which ever it is. A window manager has to
> provide window decoration, placement and so on, but no real working space,
> only frames into which other applications would run and set up an
> environment.
> This was my sysadmin point of view. And I tested it:
> Logging off from my X session, going into some console to:
> - stop my X server as root
> - connect with normal user into a console (arrived of course in my $HOME)
> - cd /tmp with taht user/console
> - launch stratx from that console, still in /tmp
> The result was openbox started without using my ~/.config/openbox files (no
> tint2 for a taskbar and so on) and the xterm I ran were all started into
> /tmp rather than my own home directory.
> So when Openbox is starting or running it is not changing the current
> directory to $HOME.
> Once back into my console I killed Openbox (ctrl + C...) and then my shell
> was still positionned into /tmp too.
> So Openbox do not change the directory in the terminal you use to launch
> startx.
> I'm using a Gentoo (modified to use systemd rather sysvinit but I don't
> think impact at all the startx script, it impacts when running X and Openbox
> system wide) and so my startx script could be different from yours, I don't
> knkow what system you are using.
> On this system startx script is part of xinit package in version 1.3.3. I
> mentionned that because I expect this directory switch is done by the
> command you are using to launch Openbox, which seems to be startx.
> Cheers,
> mathias

More information about the openbox mailing list