[openbox] Strange issue, x11 apps started by openbox, output problem.

Dana Jansens dana at orodu.net
Sun Feb 28 21:04:58 EST 2010

On Sun, Feb 28, 2010 at 11:57:47PM +0100, Piotr Karbowski wrote:
> On Sun, Feb 14, 2010 at 9:35 PM, Piotr Karbowski <jabberuser at gmail.com> wrote:
> > No luck, recompiled whole system (~800 packages) still the same issue
> > with openbox. How can I debug it? gdb and fancy switches?
> If anyone interesed I did workaround, I use much gmrun (alt+f2) to
> exec something, my openbox menu is empty. So I added wrapper to gmrun:
> % cat bin/gmrun
> #!/bin/sh
> exec /usr/bin/gmrun > /dev/null 2>&1
> and now, when I run for example psi from gmrun, it not abusing CPU. So
> problem is that openbox have problem with handle output. I have latest
> Xorg what can be found in gentoo ~arch, maybe there is problem?
> Fluxbox amd Pekwm do not have any problems with it so it must be
> openbox bug.

It should work without this work-around in the latest version of Openbox, as we addressed this problem.  If you find it to be otherwise, please let us know.


More information about the openbox mailing list