openbox3 won't compile

Ruslan N. Balkin baron at
Sun Aug 10 03:20:53 EDT 2003


I think I first tried OB3 when it was almost completely unusable, but
now I read the ML and decided to check it again.
But unfortunately it won't compile. I think it could be a problem of my
Linux distribution, but if this is possible, please help me :)
First, I got the warnings on running bootstrap (todays CVS HEAD):
baron at localhost% ./bootstrap
+ autopoint --force
cvs [checkout aborted]: no such tag gettext-0_12_1
find: archive: No such file or directory
find: archive: No such file or directory
/usr/bin/autopoint: line 261: fatal_error: command not found
find: tmpwrk30543/archive: No such file or directory
+ libtoolize --copy --force --automake
+ aclocal -I m4
+ autoconf
+ automake --foreign --include-deps --add-missing --copy bin_PROGRAMS was already defined in condition TRUE,
which implies condition OBCONF_TRUE

  bin_PROGRAMS (User, where = +=
    TRUE => \
	kernel/openbox \

Use of uninitialized value in hash element at /usr/bin/automake-default
line 8459. Use of uninitialized value in list assignment at
/usr/bin/automake-default line 8448. Use of uninitialized value in
concatenation (.) or string at /usr/bin/automake-default line 8449.:
warning: automake does not support bin_PROGRAMS being defined
conditionally invalid unused variable name:
invalid unused variable name:

You are now ready to run ./configure

Configure runs fine... No complaints.

But when I run make, I got the error:
source='render/color.c' object='render/color.lo' libtool=yes \
depfile='render/.deps/color.Plo' tmpdepfile='render/.deps/color.TPlo' \
depmode=gcc3 /bin/sh ./depcomp \
/bin/sh ./libtool --silent --mode=compile gcc -DPACKAGE_NAME=\"openbox\"
-DPACKAGE_TARNAME=\"openbox\" -DPACKAGE_VERSION=\"3.0-alpha4\"
-DPACKAGE_STRING=\"openbox\ 3.0-alpha4\"
-DPACKAGE=\"openbox\" -DVERSION=\"3.0-alpha4\" -DDEBUG=1
-DXRANDR=1 -DVIDMODE=1 -DSHAPE=1 -DXINERAMA=1  -I. -I. -I.    -g -O2 -g
-fno-inline -Wall -Wsign-compare -Waggregate-return -Wcast-qual
-Wbad-function-cast -Wpointer-arith -c -o render/color.lo `test -f
'render/color.c' || echo './'`render/color.c

In file included from render/render.h:5,
                 from render/color.c:1:
/usr/include/X11/Xft/Xft.h:52: syntax error before "_XftFTlibrary"
/usr/include/X11/Xft/Xft.h:86: syntax error before "FT_UInt"

make[1]: *** [render/color.lo] Ошибка 1
Weel, I know that is because of freetype2 includes are not added to gcc
flags. But the include path was determined correctly (pkgconfig reports
the proper path):
baron at localhost% grep freetype2 Makefile                                
GTK_CFLAGS = -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include
-I/usr/include/atk-1.0-I/usr/include/pango-1.0 -I/usr/X11R6/include
XFT_CFLAGS =-I/usr/X11R6/include -I/usr/include/freetype2  

then I got the errors about necessary #define's are not defined:
render/theme.c:75: `DEFAULT_THEME' undeclared (first use in this
render/theme.c:950: `THEMEDIR' undeclared (first use in this function)
Well, I tried adding these to DEFS.
This time, build goes ok.

baron at localhost% ./kernel/.libs/openbox3                                
./kernel/.libs/openbox3: relocation error:
./kernel/.libs/openbox3: undefined symbol: theme_a_focused_pressed_max

baron at localhost% LC_ALL=C grep -ri focused_pressed_max ./               
Binary file ./render/.libs/ matches
Binary file ./render/.libs/ matches
Binary file ./render/.libs/ matches

Don't know what else to say. May this be problem with my libtool or
auto*? (GNU libtool) 1.4.2 (1.922.2.54 2001/09/11 03:33:37)
automake (GNU automake) 1.6.3
autoconf (GNU Autoconf) 2.57

WBR, Balkin Ruslan

More information about the openbox mailing list