SIGSEGV [segmentation fault]

Sam C-D kno333 at
Thu Dec 27 09:36:29 EST 2007

Hi, I am having troubles starting my server.  When I run my command to 
start a server, I get a SIGSEGV [segmentation fault].
Here is my output from my command:
[kno3 at lizzy Binaries]$ ./ut3 server 
login=XXXX password=XXXX
Init: Version: 3518
Init: Epic Internal: 0
Init: Compiled: Dec 17 2007 12:17:34
Init: Command line: server 
login=kno333 password=impulse
Init: Base directory: /home/kno3/ut3-dedicated/Binaries/
Init: Character set: Unicode
Log: GConfig::LoadFile has loaded file:  ../UTGame/Config/UTEditor.ini
Log: GConfig::LoadFile has loaded file:  
Log: GConfig::LoadFile has loaded file:  ../UTGame/Config/UTEngine.ini
Log: GConfig::LoadFile has loaded file:  ../UTGame/Config/UTGame.ini
Log: GConfig::LoadFile has loaded file:  ../UTGame/Config/UTInput.ini
Log: GConfig::LoadFile has loaded file:  ../UTGame/Config/UTUI.ini
Init: File handle limit is soft=(1024), hard=(1024).
Init: Computer: unknown
Init: User: kno3
Init: BSD Sockets initialized
Init: Presizing for 83221 objects not considered by GC, pre-allocating 0 
Init: Object subsystem initialized
Init: Startup System Settings:
Init: System Settings:
Init:   StaticDecals=true
Init:   DynamicDecals=true
Init:   DynamicLights=true
Init:   DynamicShadows=true
Init:   LightEnvironmentShadows=true
Init:   CompositeDynamicLights=false
Init:   DirectionalLightmaps=true
Init:   MotionBlur=true
Init:   DepthOfField=true
Init:   Bloom=true
Init:   QualityBloom=true
Init:   Distortion=true
Init:   DropParticleDistortion=false
Init:   SpeedTreeLeaves=true
Init:   SpeedTreeFronds=true
Init:   OnlyStreamInTextures=false
Init:   LensFlares=true
Init:   FogVolumes=true
Init:   FloatingPointRenderTargets=true
Init:   Trilinear=false
Init:   OneFrameThreadLag=true
Init:   UseVsync=false
Init:   UpscaleScreenPercentage=true
Init:   Fullscreen=false
Init:   AllowD3D10=true
Init:   EnableHighPolyChars=false
Init:   SkeletalMeshLODBias=0
Init:   ParticleLODBias=0
Init:   DetailMode=2
Init:   ShadowFilterQualityBias=0
Init:   MaxAnisotropy=4
Init:   MaxMultisamples=1
Init:   MinShadowResolution=32
Init:   MaxShadowResolution=512
Init:   ResX=800
Init:   ResY=600
Init:   ScreenPercentage=100.000
Init:   SceneCaptureStreamingMultiplier=1.000
Init:   FoliageDrawRadiusMultiplier=1.000
Init:   ShadowTexelsPerPixel=2.000
Log:    TEXTUREGROUP_World: (MinLODSize=   1,MaxLODSize=4096,LODBias=0)
Log:    TEXTUREGROUP_WorldNormalMap: (MinLODSize=   
Log:    TEXTUREGROUP_WorldSpecular: (MinLODSize=   
Log:    TEXTUREGROUP_Character: (MinLODSize=   1,MaxLODSize=4096,LODBias=0)
Log:    TEXTUREGROUP_CharacterNormalMap: (MinLODSize=   
Log:    TEXTUREGROUP_CharacterSpecular: (MinLODSize=   
Log:    TEXTUREGROUP_Weapon: (MinLODSize=   1,MaxLODSize=4096,LODBias=0)
Log:    TEXTUREGROUP_WeaponNormalMap: (MinLODSize=   
Log:    TEXTUREGROUP_WeaponSpecular: (MinLODSize=   
Log:    TEXTUREGROUP_Vehicle: (MinLODSize=   1,MaxLODSize=4096,LODBias=0)
Log:    TEXTUREGROUP_VehicleNormalMap: (MinLODSize=   
Log:    TEXTUREGROUP_VehicleSpecular: (MinLODSize=   
Log:    TEXTUREGROUP_Effects: (MinLODSize=   1,MaxLODSize=4096,LODBias=0)
Log:    TEXTUREGROUP_Skybox: (MinLODSize=   1,MaxLODSize=4096,LODBias=0)
Log:    TEXTUREGROUP_UI: (MinLODSize=   1,MaxLODSize=4096,LODBias=0)
Log:    TEXTUREGROUP_LightAndShadowMap: (MinLODSize=   
Log:    TEXTUREGROUP_RenderTarget: (MinLODSize=   
Init: Friendly System Settings:
Init:   TextureDetail=Level5
Init:   WorldDetail=Level5
Init:   bUseVSync=0
Init:   bUseMSAA=0
Init:   ScreenPercentage=100
Init:   UpscaleScreenPercentage=1
Init:   ResX= 800
Init:   ResY= 600
Init:   Fullscreen=0
Signal: SIGSEGV [segmentation fault]

Developer Backtrace:
Log: [ 1]  ./ut3-bin [0x8d44a12]
Log: [ 2]  [0xffffe500]
Log: [ 3]  ./ut3-bin [0x8051b5d]
Log: [ 4]  ./ut3-bin [0x804b6e2]
Log: [ 5]  /lib/ [0x49008dec]
Log: [ 6]  ./ut3-bin [0x804adc1]

Crash information will be saved to your logfile.
Exit: Exiting.
Exit: Name subsystem shutting down

I have created a symlink in /lib to, and I have edited 
my /etc/ and added the path to the binary folder of my UT3 
server.  Still no luck, get the same error all along.  I also get no 
change whether I start it "./ut3 server" or "./ut3-bin server"

Any help would be greatly appreciated.


More information about the ut3 mailing list