ECE bomb [w/latest patch]

Tom Emerson osnut at
Sun Oct 10 22:51:32 EDT 2004


I got tired of constantly getting "server refused to send the file ..." [after 
reaching 100% downloaded], so I decided to download the ECE pack to at least 
get some new maps.  I have the latest patch installed [or so the log says] 
and after un(B)zipping the file and copying over my installation, my startup 
log reads as such:

Log: Log file open, Sun Oct 10 19:40:46 2004
Init: Name subsystem initialized
Init: Version: 3323 (128.29)
Init: Compiled: Sep 10 2004 04:25:40
Init: Command line: 
Init: (This is Linux64 patch version 3323.0)
Init: Character set: Unicode
Init: Base directory: /home/tom/ut2004/System/
Init: Ini:UT2004.ini   UserIni:User.ini
Init: Build label: UT2004 Build UT2004_Build_[2004-09-07_17.17]
Init: Object subsystem initialized
Warning: Missing Class Class Editor.TransBuffer
Log: Initializing OpenGLDrv...
Log: binding
Log: Game class is 'GameInfo'
Log: Bringing Level Entry.myLevel up for play (0) appSeconds: 3.325897...
ScriptLog: GameInfo::InitGame : bEnableStatLogging False
Log: Browse: 
Log: Collecting garbage
Log: Purging garbage
Log: Garbage: objects: 33496->33495; refs: 347606
Log: Game class is 'CinematicGame'
Log: Bringing Level NvidiaLogo.myLevel up for play (0) appSeconds: 4.904631...
ScriptLog: GameInfo::InitGame : bEnableStatLogging False
Log: Created and initialized a new SDL viewport.
Critical: ReadFile beyond EOF 0+4/0
Exit: Executing UObject::StaticShutdownAfterError
Exit: Executing USDLClient::ShutdownAfterError
Exit: Exiting.
Log: FileManager: Reading 0 GByte 53 MByte 1001 KByte 524 Bytes from HD took 
0.425802 seconds (0.242561 reading, 0.183241 seeking).
Log: FileManager: 0.000000 seconds spent with misc. duties
Uninitialized: Name subsystem shut down
Uninitialized: Log file closed, Sun Oct 10 19:40:51 2004

I think I've seen a message regarding the "missing class Editor.TransBuffer" 
before (though I don't know if that's a problem if all you want to do is 
play, not edit maps...), but the one that torques me is "Critical: ReadFile 
beyond EOF 0+4/0" -- WHAT damn file did it try to read past the EOF?  Did 
something get corrupted along the way?  Could I try to find/repair the file?  
[like add four spaces to the end, so at the very least it won't crap out on 
EOF?  'course, those missing 4 bytes might hold something important and 
spaces weren't it :) ]

Looks like I'm off the player roster till this gets fixed -- I don't really 
want to go through the hassle of re-install / re-patch / re-patch / 
re-patch / re-patch..... until I'm back to "current" :(

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: signature
URL: <>

More information about the ut2004 mailing list