[ut2004] 64 bit client problems with downloads

Tom Emerson osnut at pacbell.net
Wed Nov 17 22:06:07 EST 2004

On Wednesday 17 November 2004 5:12 pm, Clint Goudie-Nice wrote:
> > As I recall, there is a bug in the download meter on x86_64.  It's not a
> > big problem, as downloading still works, so it's pretty low priority.

of course, from my point of view, I have to ask, "why is there a bug in the 
first place?" this is pretty simple stuff we're talking about: you're getting 
a file, you know how big it is, and you know how many bytes you've received 
-- not rocket science...

> Well it kind of works, the larger problem is that it pulls from the web
> server, then when it's finished it stops, and starts pulling from the UT
> server instead. I tested this out by disabling downloads directly from
> the UT server, and after the download completes the first time, I get
> the "Server refused to send file" message.

Bingo!  I'm seeing the same thing with lots of sites as well.  From what you 
are saying, though, is that the file was indeed received initially -- is 
there an easy way to confirm that the file was indeed FULLY received?  Maybe 
the "bug" is simply that the download routine doesn't recognize the fact that 
it did get the complete file from the main web server, and, as you say, tries 
to get it from the "hosting" server?

A side point: is there a way [short of running ethereal] to determine what the 
program wants from the "web" server?  I'm thinking I should just run wget to 
pull all the files before I even run UT, thus avoiding the need to download 
anything during the game...

More information about the ut2004 mailing list