[ut2004] Cant find libGL

Rick B zajelo3 at cfl.rr.com
Tue Jul 20 03:55:11 EDT 2004

Robert Larkin wrote:

> Luke Bigum wrote:
>> This is interesting. I'm running a Gentoo box and after just updating 
>> nvidia-glx UT2004 cant load the openGL libraries, however every
>> other app that uses OpenGL has no problems. Is there some .ini 
>> setting to tell UT where to look for libraries?
>> This is the log:
>> Log: Log file open, Tue Jul 20 15:54:59 2004
>> Init: Name subsystem initialized
>> Init: Version: 3236 (127.29)
>> Init: Compiled: Jun 20 2004 09:32:48
>> Init: Command line:
>> Init: (This is Linux patch version 3236.1)
>> Init: Character set: Unicode
>> Init: Base directory: /usr/local/games/ut2004/System/
>> Init: Ini:UT2004.ini   UserIni:User.ini
>> Init: Build label: UT2004 Build UT2004_Patch_[2004-06-11_16.51]
>> Init: Object subsystem initialized
>> Warning: Missing Class Class Editor.TransBuffer
>> Log: Initializing OpenGLDrv...
>> Log: binding libGL.so.1
>> Critical: Could not load OpenGL library
>> Exit: Executing UObject::StaticShutdownAfterError
>> Exit: Executing USDLClient::ShutdownAfterError
>> Exit: Exiting.
>> Log: FileManager: Reading 0 GByte 41 MByte 885 KByte 607 Bytes from 
>> HD took 7.338239 seconds (1.810004 reading, 5.528235 seeking).
>> Log: FileManager: 0.000000 seconds spent with misc. duties
>> Uninitialized: Name subsystem shut down
>> Uninitialized: Log file closed, Tue Jul 20 15:55:12 2004
> On my system /usr/X11R6/lib/libGL.so.1 is a symlink to libMesaGL.so 
> which is a symlink to nvidia's opengl.  Is it the same on yours? (I'm 
> also on Gentoo).  I believe "opengl-update nvidia" does this, although 
> I know I did not execute this after emerging the latest nvidia 
> drivers, the ebuild seems to have updated the symlink for me.
> Rob
> Rob
    You can run nvidia-check on it, and it will tell you if anything is 
wrong with your setup and I think it also tell's you how to fix 
incorrect setups. I've attached it, because I googled for it and 
couldn't find it just now. But I don't know if the mail server will let 
the attachment get through. If not and you can't find it, email me at 
zajelo3 at cfl . rr . com and I will send it to you..

                Rick B
          Rick B
-------------- next part --------------
A non-text attachment was scrubbed...
Name: nv_check.sh
Type: application/x-sh
Size: 11073 bytes
Desc: not available
URL: <http://icculus.org/pipermail/ut2004/attachments/20040720/2380a238/attachment.sh>

More information about the ut2004 mailing list