[ut2004] One more OpenAl question

Jason Paque solitudewi at yahoo.com
Thu Apr 22 20:47:31 EDT 2004

rix <zajelo3 at cfl.rr.com> wrote:Jason Paque wrote:

> use your lspci program to retrieve the hardware list for the right 
> setting for the soundcard.
> you have to look under /usr/bin to find the lspci prog for every 
> distro it is aparently different.
> */rix /* wrote:
> rix wrote:
> > Hi all,
> > All right, I got my openal set up mostly right except I get some
> > static when the game starts. I have a feeling it's the
> >
> > (define alsa-out-device "hw:0,0") comment in .openalrc. How do you
> > know what the "out-device" is on any particular machine? Is the
> > "hw:0,0" representative of the pci bus location of the sound
> card? I
> > have tried "default" instead of "hw:0,0" that doesn't work at all.
> > Also, I got like a 3 fps performance boost out of this tweak.
> Thanks
> > guys for helping out.
> >
> > Rick B.
> >
> >
> Nevermind, I found some documetation and from what I learned "hw:0,0"
> should be the right output. I'll fiddle with it 'till I get it right.
> Maybe it's "plughw:0,0".
> Rick B
I originally thought that the pci location of the sound card was what I 
should use (lspci -v tells me 00:06.0 is my sound card) but that's not 
right. I learned that if you do a "cat /proc/asound/devices":

0: [0- 0]: ctl
25: [0- 1]: digital audio capture
16: [0- 0]: digital audio playback
24: [0- 0]: digital audio capture
33: : timer

If you look at the third line down you will see "16: [0- 0]: digital 
audio playback" the [0- 0] is what ALSA wants to know, apparently so it 
knows how to send the output. If you have a card with more than one 
output, like an extra SPDIF out, you will have more than one "digital 
audio playback" device listed, so you will have to find out which one 
can be used.

Rick B 
from what I see on your list there are going to be conflicts when you init audio playback as it will be recaptured unless I am reading it wrong you have 3 functions tied to the same device parameters
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://icculus.org/pipermail/ut2004/attachments/20040422/41d8c66d/attachment.htm>

More information about the ut2004 mailing list