[ut2004] Voice chat

Ryan C. Gordon icculus at clutteredmind.org
Thu Apr 22 02:30:27 EDT 2004

On Mon, 2004-04-19 at 16:28, Kristopher Kersey wrote:
> Which openal.so and libSDL-1.2.so.0 are you using?  The ones that came
> with UT or your system ones?  Which distro are you using?  If you are
> still using the ones UT came with, I recommend linking
> System/libSDL-1.2.so.0 and System/openal.so to your system libs.  Make
> sure you have the alsa libs and utils installed as well.

btw, it's probably not a good idea to tell people to swap out the
openal/SDL unless they know what they're doing, or it eventually results
in a bogus bug report to me.

If people are using this with something like the Gentoo ebuilds which
will swap out the libraries with something known to be good, that's
fine, but since there's a lot of ut2004-specific fixes that went into
SDL and OpenAL cvs around when we went gold, just swapping in whatever
happens to be on someone's system is NOT a good idea, since it could be
several years out of date.

I bring this up because everyone's flinch reaction is to swap out the
LGPL'd libraries now, and it's actually causing more problems than it's
solving for many people. Like, "I had a crash, so I changed out SDL.
Game still crashes." or "I stubbed my toe when I got out of bed this
morning, so I swapped out the openal.so in my ut2004 install. Toe still


More information about the ut2004 mailing list