[ut2003io] No Readme dialog box

Leith leith at qasr.mine.nu
Tue Oct 1 22:29:48 EDT 2002


Thanks for your reply. I do have write access, i was installing to 
~/UT2003. I tried unchecking the symlink box as well as putting a valid 
entry for where I might like a symlink. Interestingly if I uncheck the 
symlink box, then check it again, I get this error in the console:

Gtk-WARNING **: invalid cast from (NULL) pointer to `GtkEntry'

Gtk-CRITICAL **: file gtkentry.c: line 490 (gtk_entry_get_text): 
assertion `entry != NULL' failed.

I do have adequate free space, and the instller reports it accuratley 

If I unset the DISPLAY env variable, I get this.

leith at qasr:/mnt/cdrom$ ./linux_installer.sh
Copying to a temporary location...
Verifying archive integrity... All good.
Uncompressing Unreal Tournament 2003 for GNU/Linux 
No UI drivers available
----====== Unreal Tournament 2003 installation program ======----

You are running a x86 machine with glibc-2.1
Hit Control-C anytime to cancel this installation program.

There is then no response to anything typed into the console, so I 
Ctrl-C, and it quits gracefully. Still no install though =)

Any other ideas?



Ryan C. Gordon wrote:

> Leith wrote:
>> Hi All,
>> I have tried running  the installer from the CD, and also my home 
>> directory. I have tried running it as root as well as a user. I am 
>> not mounting using supermount, or whatever that is. Typing mount 
>> gives me:
>> /dev/hdd on /mnt/cdrom type iso9660 (ro,user=leith)
>> The entry in /etc/fstab is:
>> /dev/hdd    /mnt/cdrom    iso9660    ro,user,exec,suid,dev    0    0
>> My problem is, I cannot get past the first screen that comes up. It 
>> asks for a install dir, and after I enter it the free space field 
>> gets filled in, and the begin install button is greyed out.
> Do you have write access to the directory where it wants to put 
> symlink?  Is there really enough freespace in the install directory's 
> filesystem and do you REALLY have write access there?
> If so, from the command line, do:
>   unset DISPLAY
> before running the thing and see if the text-based install works for you.
> --ryan.

More information about the ut2003 mailing list