[smpeg] Problem building using MMX under mingw

René Dudfield renesd at gmail.com
Fri Aug 18 18:34:00 EDT 2006


if you get smpeg working with mingw I'd really like to know.  Last
time I tried about a year ago I couldn't get it going.


On 8/18/06, Matthew Bentley <moc.pophot at hotpop.com> wrote:
> Hi all-
> I'm currently working on SMPEG, putting a bunch of optimizations into the
> code- two questions:
> 1. How do I submit (potential) new versions of .cpp & .h to the CVS, and 2.,
> I'm 'make'ing under msys, mingw, and the asm code gives me back a bunch of
> errors if I try to include MMX code - here's the error:
> "/bin/sh ./libtool --mode=compile gcc  -DUSE_MMX -c -o mmxflags_asm.lo
> `test -f '
> video/mmxflags_asm.S' || echo './'`video/mmxflags_asm.S
>  gcc -DUSE_MMX -c video/mmxflags_asm.S  -DDLL_EXPORT -DPIC -o
> .libs/mmxflags_asm
> .o
> video/mmxflags_asm.S: Assembler messages:
> video/mmxflags_asm.S:7: Warning: .type pseudo-op used outside of .def/.endef
> ign
> ored.
> video/mmxflags_asm.S:7: Error: junk at end of line, first unrecognized
> character
>  is `c'
> video/mmxflags_asm.S:49: Warning: .size pseudo-op used outside of
> .def/.endef ig
> nored.
> video/mmxflags_asm.S:49: Error: junk at end of line, first unrecognized
> characte
> r is `c'
> make: *** [mmxflags_asm.lo] Error 1"
> Now I'm pretty new to make etc- but I've hunted the internet up and down,
> and the best page I could come up with was this:
> http://www.gentoo.org/proj/en/hardened/pic-fix-guide.xml :and it doesn't
> tell me how to fix the errors in the more recent code, only the old stuff
> (which, by the way, won't compile either): I'm using the latest CVS code-
> have also tried .44- any help you
> could give would be much appreciated-
> Thanks,
> Mat

More information about the smpeg mailing list