[physfs] Why is my PhysFS class is corrupting the first few bytes of files?

Taha Mirza bowserevilking at gmail.com
Tue Nov 20 19:45:51 EST 2012

On 20/11/2012 7:11 PM, Christoph Nelles wrote:
> Have you tried a debugger? Have you tried to expand your code and use
> intermediate variables and outputting their address (or evaluate them
> with a debugger?). Es especially the Vector may be interesting. Have you
> tried using plain memory (new[]/malloc)?
> Am 21.11.2012 01:06, schrieb Taha Mirza:
>> Right, so, um, I'll just link to the StackOverflow question I made:
>> http://stackoverflow.com/questions/13443456/physfs-corrupting-first-few-bytes-of-data
>> It's in C++11, and I know PhysFS is a C library, so forgive me if you
>> can't glean my problem. I can't either. :-[
>> Thanks for taking a look.
>> _______________________________________________
>> physfs mailing list
>> physfs at icculus.org
>> http://icculus.org/mailman/listinfo/physfs
Ah, yes, you've got me to use new[], and it works perfectly. It seems to 
be a C++ issue rather than a PhysFS issue, because even when manually 
copying the perfect array into the vector, the vector is /still/ messed up.

But anyways, thank you kindly. I guess there really wasn't any point to 
a vector, was there? :-D
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://icculus.org/pipermail/physfs/attachments/20121120/659f026d/attachment.htm>

More information about the physfs mailing list