[obdgpslogger] Switching to Windows/Cygwin, can't get OBD data

Gary Briggs chunky at icculus.org
Sat Jul 17 15:03:55 EDT 2010

On Sat, Jul 17, 2010 at 02:12:40PM -0400, Robert Konigsberg wrote:
> Hi,
> I've had to make a last-minute change and go from OSX to Windows/Cygwin. I
> know Cygwin well enough so it's not much of a shift, but some things are
> preventing me from succeeding.
> Using only the code from the svn repository, I compiled, built and installed
> the obdgpslogger, and associated tools. Plugged in the USB device.
> Now, I know that the device is COM3, and that it's bound to /dev/ttyS2. I
> know this because when I unplug the device and run the logger with
> /dev/ttyS2, I get this message:
> "/dev/ttyS2: no such file or directory. / Couldn't open obd serial port.
> Attempting to continue. / Couldn't find either gps or obd to log. Exiting."
> And when I plug it in, I get this:
> "Opening serial port /dev/ttyS2. this can take a while / Successfully
> connected to serial port. Will log obd data / Couldn't get obd data for cmd
> 00 / here".
> I can see when this is happening that the OBD USB device only has two
> lights: the power light, and the occasional "PC / RX" light.
> So, that's odd. What are your thoughts?

I would suspect the baudrate isn't set right. Try passing the right
baudrate directly ["-b 38400], or try running with "-b 0" and see if it
guesses it?

If that's still not the case, save the serial log and see what it
contains? ["-l logfile.txt"]

I just tried a fresh checkout under cygwin, seems to be working here.

Gary (-;

More information about the obdgpslogger mailing list