[lokisetup] Proper patch for gtk2 support

Stéphane Peter megastep at megastep.org
Tue Feb 7 18:19:13 EST 2006

Actually I have run in the same problem a little while ago, in a  
different project. The solution is to simply move setupdb to libxml2.  
This can be easily done at compile time with a few macros, since the  
APIs are essentially identical. Linking with the 2 different versions  
of the library is just a bad idea.

We'll also need to make sure that setupdb is compiled with libxml2  
support when enabling GTK2. So more patching work is in order.

On Feb 7, 2006, at 2:14 PM, Ludwig Nussel wrote:

> Jeremy White wrote:
>> The attached is a better patch to enable gtk2 support; it is
>> more surgical, and gtk2 is now optional.
>> It adds a --enable-gtk2 configure option which, if selected,
>> builds setup.gtk and xsu with gtk2 tools instead of gtk1.
> Since loki-setup and loki-setupdb use libxml and glade2 uses libxml2
> the resulting application will be linked against both at the same
> time...
> cu
> Ludwig
> -- 
> (o_  Ludwig.Nussel at gmx.de
> //\
> V_/_ PGP Key ID: FF8135CE

Stéphane Peter
megastep at megastep.org

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://icculus.org/pipermail/lokisetup/attachments/20060207/5c0fd022/attachment.htm>

More information about the Lokisetup mailing list