[lokisetup] Loki Setup ; installation problems -- Please Help

Stéphane Peter megastep at megastep.org
Wed Aug 3 20:54:43 EDT 2005

The error you get comes from the tar extraction plugin, which does  
not directly call the tar command but rather has some code from GNU  
tar to extract it from within Loki setup. The type of compression you  
use is irrelevant as it is handled separately.

This particular error is triggered with one of the files inside the  
tar archive is of a type not handled by this code. It is mysterious  
exactly what would be the problem in this case. What is the type of  
files for which you get this error? We don't handle a few of the  
types usually supported by tar archives, i.e. sockets and the like.  
Files, directories, symbolic links should be fine though.

On Aug 2, 2005, at 9:34 PM, Ram wrote:

> I am using loki setup and i have given a tar file which contains
> 1000's of binaries as an argument to <files>mytarfile.tar.gz</file>
> When i try to install i get the following messages and the file (which
> appears in the warning messages) dont get installed.
> Tar: 'bootloader/tools-3.2.2/arm-linux/bin/g++' is unknown file  
> type: 1
> I get messages like the above many times.
> I tried with both .tar.gz format and .tar.bz2 format and i get
> messages like above.
> I dont think there is a problem with the tar files as they work
> properly when i invoke them as a shell command.
>    tar -xvzf mytarfile.tar.gz  works file on my system.
> I cant specify the files to be installed as the number of files run
> into thousands and i cant put them all in a cd. only way i can put
> them is compress them and put it.
> How do i resolve this problem.
> Regards,
> Sriram

Stéphane Peter
megastep at megastep.org

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://icculus.org/pipermail/lokisetup/attachments/20050803/cdaf2926/attachment.htm>

More information about the Lokisetup mailing list