[lokisetup] xsu broken?

Timothee Besset ttimo at idsoftware.com
Thu Apr 10 03:45:35 EDT 2003

Here's what happens here on a -DDEBUG build of xsu:

timo at sparkle:~/Build/loki_setup$ ./xsu -e -a -u root -c "touch it"
on_gtk_user_textbox_activate (GtkButton *button, gpointer user_data)
void xsu_perform()
reading from pty: 'Password:'
Got it!
Sending password
end xsu_perform

It never returns. And it is not being created. Attaching my binary.
Happens when I run on Debian Sid, for an xsu compiled on Debian Sid, or on
the Holy Box (modified Mandrake 7.2 - glibc 2.1)


On Wed, 9 Apr 2003 21:14:28 -0700
John Quigley <jmquigs at bigfoot.com> wrote:

> It sorta works for me.  If I run 
> ./xsu -e -a -u root -c "touch it"
> I get a root-owned "it" file.  But if I run
> ./xsu -e -a -u root -c "xterm"
> I don't get an xterm.  (Even if I set DISPLAY env)  Running on gentoo now but 
> I built xsu on my redhat 7.3 box.  
> On Wednesday 09 April 2003 8:12 pm, Stéphane Peter wrote:
> > I have been using the current xsu from CVS for quite some time, and at
> > least on Linux it seems stable enough. Are you running this maybe on a
> > newer distribution ?
> >
> > > Can anyone successfully run the current xsu binary? It fails here, both
> > > with a local build and the holy box build of xsu. I get the dialog, I
> > > enter the command and the user information, then I see an su process
> > > spawned. And nothing happens, + su doesn't exit.

More information about the Lokisetup mailing list