[lokisetup] GTK+ requirements?

Stephane Peter megastep at megastep.org
Wed Feb 13 18:19:56 EST 2002

On Wed, 2002-02-13 at 13:25, Ryan C. Gordon wrote:
> What was Loki's strategy for distributing Setup binaries, in regards to
> GTK+? Were they statically linked against a specific known-good version,
> or dynamically linked, or what?

They were dynamically linked against GTK+ 1.2.x. If dependencies failed,
there is always the text-based installer which is statically linked.

> What version of GTK+ should we be using with Setup? Do certain versions
> break compatibility, etc?

You need a 1.2 version to compile, but if you intend to support glibc
2.0 as well you'll need to build separate binaries as they are not
compatible with glibc >= 2.1 for some reason!
Stephane Peter
Software Engineer
Codehost, Inc.

More information about the Lokisetup mailing list