[Gtkradiant] GTKRadiant Bug Report noreply at qeradiant.com
Tue Oct 26 09:37:57 CDT 2004

This bug report was submitted from using the Bug Report Submission Form on the QERadiant Website at 09:37:56 CDT Oct 26, 2004.



CPU/RAM/Operating System: Duron 1.2G / 256MB RAM / MandrakeLinux 10.0
Hard Drive Space: 56 GB
Video Card/OpenGL Drivers: GForce2 GTS
Version of GTKRadiant:  gtkradiant-1.5.0-2004-09-26.i386.rpm

I can not install the rpm on my Mandrake 10.0 because Mandrake don't have the needed dependances :

[root at localhost devel]# urpmi gtkradiant-1.5.0-2004-09-26.i386.rpm
Certains paquetages demandés ne peuvent pas être installés : (some packages can not be installed)
gtkradiant-1.5.0-1.i386 (car libgtkglext-x11-1.0.so.0  est non satisfait) (O/n)
[root at localhost devel]#
(because libgtkglext-x11-1.0.so.0 is needed)

if i use only rpm -i :
[root at localhost devel]# rpm -i gtkradiant-1.5.0-2004-09-26.i386.rpm
erreur: Dépendances requises:
        gtk2 >= 2.4.0 est nécessaire pour gtkradiant-1.5.0-1
        gtkglext >= 1.0.0 est nécessaire pour gtkradiant-1.5.0-1
        libgdkglext-x11-1.0.so.0 est nécessaire pour gtkradiant-1.5.0-1
        libgtkglext-x11-1.0.so.0 est nécessaire pour gtkradiant-1.5.0-1

I show you what i have in my /usr/lib folder :
[root at localhost devel]# cd /usr/lib
[root at localhost lib]# ls libgtk*
libgtk-1.2.so.0@      libgtkgl.so.5.0.0*        libgtkhtml-2.so.0.0.0*      libgtkxmhtml.so.1.0.1*
libgtk-1.2.so.0.9.1*  libgtkhtml-1.1.so.3@      libgtk-x11-2.0.so.0@
libgtkgl.so.4@        libgtkhtml-1.1.so.3.0.5*  libgtk-x11-2.0.so.0.200.4*
libgtkgl.so.5@        libgtkhtml-2.so.0@        libgtkxmhtml.so.1@

I have installed the package with the --nodeps arg, but the binary need libgtkglext-x11-1.0.so.0 and libgdkglext-x11-1.0.so.0:

[alan at localhost gtkradiant]$ ldd ./radiant.x86
        linux-gate.so.1 =>  (0xffffe000)
        libdl.so.2 => /lib/libdl.so.2 (0x40027000)
        libglib-2.0.so.0 => /usr/lib/libglib-2.0.so.0 (0x4002a000)
        libxml2.so.2 => /usr/lib/libxml2.so.2 (0x40097000)
        libz.so.1 => /lib/libz.so.1 (0x40196000)
        libpthread.so.0 => /lib/tls/libpthread.so.0 (0x401a7000)
        libgtk-x11-2.0.so.0 => /usr/lib/libgtk-x11-2.0.so.0 (0x401b7000)
        libgdk-x11-2.0.so.0 => /usr/lib/libgdk-x11-2.0.so.0 (0x4041d000)
        libatk-1.0.so.0 => /usr/lib/libatk-1.0.so.0 (0x4048e000)
        libgdk_pixbuf-2.0.so.0 => /usr/lib/libgdk_pixbuf-2.0.so.0 (0x404aa000)
        libm.so.6 => /lib/tls/libm.so.6 (0x404be000)
        libpangoxft-1.0.so.0 => /usr/lib/libpangoxft-1.0.so.0 (0x404e1000)
        libpangox-1.0.so.0 => /usr/lib/libpangox-1.0.so.0 (0x40504000)
        libpango-1.0.so.0 => /usr/lib/libpango-1.0.so.0 (0x40511000)
        libgobject-2.0.so.0 => /usr/lib/libgobject-2.0.so.0 (0x40545000)
        libgmodule-2.0.so.0 => /usr/lib/libgmodule-2.0.so.0 (0x4057b000)
        libgtkglext-x11-1.0.so.0 => not found
        libgdkglext-x11-1.0.so.0 => not found
        libGLU.so.1 => /usr/X11R6/lib/libGLU.so.1 (0x40584000)
        libGL.so.1 => /usr/lib/libGL.so.1 (0x40610000)
        libXmu.so.6 => /usr/X11R6/lib/libXmu.so.6 (0x40678000)
        libXt.so.6 => /usr/X11R6/lib/libXt.so.6 (0x4068f000)
        libSM.so.6 => /usr/X11R6/lib/libSM.so.6 (0x406e3000)
        libICE.so.6 => /usr/X11R6/lib/libICE.so.6 (0x406ec000)
        libstdc++.so.5 => /usr/lib/libstdc++.so.5 (0x40703000)
        libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x407c3000)
        libc.so.6 => /lib/tls/libc.so.6 (0x407cc000)
        libX11.so.6 => /usr/X11R6/lib/libX11.so.6 (0x40915000)
        /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x40000000)
        libXrandr.so.2 => /usr/X11R6/lib/libXrandr.so.2 (0x409f7000)
        libXi.so.6 => /usr/X11R6/lib/libXi.so.6 (0x409fb000)
        libXinerama.so.1 => /usr/X11R6/lib/libXinerama.so.1 (0x40a03000)
        libXext.so.6 => /usr/X11R6/lib/libXext.so.6 (0x40a06000)
        libXft.so.2 => /usr/X11R6/lib/libXft.so.2 (0x40a15000)
        libXrender.so.1 => /usr/X11R6/lib/libXrender.so.1 (0x40a27000)
        libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0x40a2f000)
        libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0x40a57000)
        libgtk-1.2.so.0 => /usr/lib/libgtk-1.2.so.0 (0x40ab6000)
        libgdk-1.2.so.0 => /usr/lib/libgdk-1.2.so.0 (0x40c05000)
        libgmodule-1.2.so.0 => /usr/lib/libgmodule-1.2.so.0 (0x40c3f000)
        libglib-1.2.so.0 => /usr/lib/libglib-1.2.so.0 (0x40c42000)
        libGLcore.so.1 => /usr/lib/libGLcore.so.1 (0x40c68000)
        libnvidia-tls.so.1 => /usr/lib/tls/libnvidia-tls.so.1 (0x41340000)
        libexpat.so.0 => /usr/lib/libexpat.so.0 (0x41343000)

i have tried by doing some shortcuts but that don't work.

And, the rpm install the binaries on the /opt folder, whitch is not in my shell PATH.

Can you give us a software that can work with some other GNU/Linux Dists please ? :-)


Cause of Error:
See above

User Email: alan.lecorre at wanadoo.fr

More information about the Gtkradiant mailing list