[bf1942] Battlefield 2 Patch 1.03 problems

David Stevens dave at netdefense.ca
Wed Oct 5 10:23:06 EDT 2005

This is almost definitely a corrupted install. I find it odd that the copy from his friends computer didn’t work though.


If someone posts some MD5 sums for all the client files, he can have a go at that.




From: [Karl]Aschnikof [mailto:ak47 at alk-wg.de] 
Sent: Wednesday, October 05, 2005 4:52 AM
To: BF2 mailing
Subject: [bf1942] Battlefield 2 Patch 1.03 problems


a guy from me has this problem:
I have the following problem concerning the installation of Battlefield 2 Patch 1.03:
When I try to install the Patch, it initializes correctly, but about 2 seconds after i click on the "install" button, I get a "Patching failed" error. YES, I have more than 2 GB free diskspace on EVERY partition, and YES, I HAVE ALREADY REINSTALLED THE GAME several times from scratch.
Next thing I tried which has helped me already on earlier BF2 Patches ( I got the Patching failed error with Patch 1.02 too) was, I copied the complete BF2 Game directory from a buddy of mine who was able to install the 1.03 Patch and replaced my own BF2 Game Directory with it.
Now the Game was patched of course, started up normally but every time I want to connect to a internet server I get a message saying "Your CD-key is not valid"
Then I completely uninstalled the game again, and reinstalled it in English from my German DVD Version. With this unpatched Installation I tried to connect to a internet Server - with SUCCESS! Everything worked as it should... invalid CD-key MY ASS!!!
Next thing I tried was to manually install the 1.03 Patch by starting the Setup, then copying all Patch files from the temporary directory in c:\documents & settings\username\local settings\temp to the BF2 Game directory (which is on D:\Games\Battlefield 2) and starting the patch.exe
The Patch seemed to work, my Installation is now patched (in main menu it says it is V. 1.1.2551.0) but AGAIN everytime I try to connect to ANY internet server, I get the "Your CD-key is not valid" message...
For now I don't have any clues what causes this problem, I already tried to change my CD Key with the little tool EA provides in the Battlefield 2\Support Directory, without any success.
Any help with this issue would be greatly appreciated!
best regards
Thomas Schlaefer a.k.a. $Le€P

[Karl]Aschnikof aka Butty
für LAN-Partys und LAN-Equipment Verleih 
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://icculus.org/pipermail/bf1942/attachments/20051005/6cb103c1/attachment.htm>

More information about the Bf1942 mailing list