[armyops] Armyops cant find drivers

Clayton Bluhm bluhmcc at auburn.edu
Sat Jan 31 20:40:07 EST 2004

The file libGL.so.1 is simlinked to libGL.so.1.0.5328.  Not libGL.a. 
Although when I try to run:
 locate libGL.a
it doesnt find that file.  Just in case you are curious glxinfo returns:

name of display: :0.0
display: :0  screen: 0
direct rendering: Yes
server glx vendor string: NVIDIA Corporation
server glx version string: 1.3
server glx extensions:
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_SGIX_fbconfig,
    GLX_SGIX_pbuffer, GLX_SGI_video_sync, GLX_SGI_swap_control,
client glx vendor string: NVIDIA Corporation
client glx version string: 1.3
client glx extensions:
    GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_visual_info,
    GLX_EXT_visual_rating, GLX_EXT_import_context, GLX_SGI_video_sync,
    GLX_NV_swap_group, GLX_SGIX_fbconfig, GLX_SGIX_pbuffer,
    GLX_SGI_swap_control, GLX_NV_float_buffer
GLX extensions:
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_SGIX_fbconfig,
    GLX_SGIX_pbuffer, GLX_SGI_video_sync, GLX_SGI_swap_control,
    GLX_ARB_multisample, GLX_ARB_get_proc_address
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce3/PCI/3DNOW!
OpenGL version string: 1.4.1 NVIDIA 53.28
OpenGL extensions:
    GL_ARB_depth_texture, GL_ARB_imaging, GL_ARB_multisample,
    GL_ARB_multitexture, GL_ARB_occlusion_query,
    GL_ARB_point_sprite, GL_ARB_shadow, GL_ARB_texture_border_clamp,
    GL_ARB_texture_compression, GL_ARB_texture_cube_map,
    GL_ARB_texture_env_add, GL_ARB_texture_env_combine,
    GL_ARB_texture_env_dot3, GL_ARB_texture_mirrored_repeat,
    GL_ARB_transpose_matrix, GL_ARB_vertex_buffer_object,
    GL_ARB_vertex_program, GL_ARB_window_pos, GL_S3_s3tc,
    GL_EXT_texture_env_add, GL_EXT_abgr, GL_EXT_bgra,
    GL_EXT_blend_minmax, GL_EXT_blend_subtract,
    GL_EXT_draw_range_elements, GL_EXT_fog_coord,
    GL_EXT_packed_pixels, GL_EXT_paletted_texture,
    GL_EXT_rescale_normal, GL_EXT_secondary_color,
    GL_EXT_separate_specular_color, GL_EXT_shadow_funcs,
    GL_EXT_shared_texture_palette, GL_EXT_stencil_wrap,
    GL_EXT_texture_compression_s3tc, GL_EXT_texture_cube_map,
    GL_EXT_texture_edge_clamp, GL_EXT_texture_env_combine,
    GL_EXT_texture_env_dot3, GL_EXT_texture_filter_anisotropic,
    GL_EXT_texture_lod, GL_EXT_texture_lod_bias, GL_EXT_texture_object,
    GL_EXT_vertex_array, GL_HP_occlusion_test, GL_IBM_rasterpos_clip,
    GL_IBM_texture_mirrored_repeat, GL_KTX_buffer_region,
    GL_NV_copy_depth_to_color, GL_NV_depth_clamp, GL_NV_fence,
    GL_NV_fog_distance, GL_NV_light_max_exponent,
    GL_NV_multisample_filter_hint, GL_NV_occlusion_query,
    GL_NV_packed_depth_stencil, GL_NV_pixel_data_range,
    GL_NV_register_combiners, GL_NV_register_combiners2,
    GL_NV_texgen_reflection, GL_NV_texture_compression_vtc,
    GL_NV_texture_env_combine4, GL_NV_texture_rectangle,
    GL_NV_texture_shader2, GL_NV_vertex_array_range,
    GL_NV_vertex_array_range2, GL_NV_vertex_program,
    GL_NVX_ycrcb, GL_SGIS_generate_mipmap, GL_SGIS_multitexture,
    GL_SGIS_texture_lod, GL_SGIX_depth_texture, GL_SGIX_shadow,
glu version: 1.3
glu extensions:
    GLU_EXT_nurbs_tessellator, GLU_EXT_object_space_tess

Thanks but this doesnt seem to be my problem.  An interesting fact is
that Enemy Territory runs fine.  It locates and uses the drivers, so
this problem is only local to UT engine based games ie. like armyops.

Any other thoughts?

On Sat, 2004-01-31 at 16:10, Zannox wrote:
> Locate your libGL.so.1 and make sure it isn't symlinked to the opengl
> libGL.a. I ran into this problem with UT2003 & Tribes 2 after upgrading
> to those drivers as well. Had all sorts of weird textrures. When I ran
> 'glxinfo' it would have some of the features of the Nvidia OpenGL driver
> but not all. The problem was because libGL.so was linked to the open
> source GL driver libGL.a. Simply removing the symlink to the libGL.a
> fixed the problem for me.
> Zannox
> On Sat, 2004-01-31 at 14:00, Clayton Bluhm wrote:
> > I am having trouble with armyops not being able to find my NVIDIA OpenGL
> > drivers.  I have just upgraded my NVIDIA drivers to 5328 (was at 3123)
> > and now Armyops, UT2003, and UT cant seem to load the drivers.  glxinfo
> > reports on the display, and glxgears runs.  Here is the exact error I
> > get from loading armyops:
> > 
> > Log: Log file open, Sat Jan 31 14:55:42 2004
> > Init: Name subsystem initialized
> > Log: Your locale: [ANSI_X3.4-1968].
> >                                                                                                                             
> > Init: Unreal Version: 2110
> > Init: AGP Version: 2110.2.0.0
> > Init: Compiled: Nov 16 2003 16:51:18
> > Init: Command line:
> > Init: Base directory: /home/nashirak/armyops/System/
> > Init: Character set: Unicode
> > Init: Object subsystem initialized
> > Init: OS Type=x86 Linux
> > Init: CPU Detected: PentiumPro-class processor (AuthenticAMD)
> > Init: CPU Features: CMov FPU RDTSC PAE MMX
> > Init: CPU Speed=1199.676880 MHz
> > Init: File handle limit is soft=(1024), hard=(1024).
> > Warning: Missing Class Class Editor.TransBuffer
> > Init: Unreal engine initialized
> > Init: Detected 0 joysticks
> > Init: SDLClient initialized.
> > Init: Initializing OpenGLDrv...
> > Log: binding libGL.so.1
> > Critical: appError called:
> > Critical: Could not load OpenGL library
> > Exit: Executing UObject::StaticShutdownAfterError
> > Exit: Executing USDLClient::ShutdownAfterError
> > Exit: Exiting.
> > Log: Waiting for file streaming thread to finish...
> > Uninitialized: Name subsystem shut down
> > Uninitialized: Log file closed, Sat Jan 31 14:55:47 2004
> > 
> > 
> > Any thoughts?  
> > Thanks
Clayton Bluhm                     bluhmcc at auburn.edu
Computer Engineering Student      http://www.auburn.edu/~bluhmcc/

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: This is a digitally signed message part
URL: <http://icculus.org/pipermail/armyops/attachments/20040131/4d537f4a/attachment.pgp>

More information about the armyops mailing list