[aquaria] Can't make the new version work on my linux box

Damien Cassou damien.cassou at gmail.com
Thu Apr 21 17:53:18 EDT 2011

Dear gentle developers,

I've just tried aquaria latest build from mercurial and can't make it
work. I can see Aquaria's interface with the 'New game', 'Continue'
and 'Exit' buttons but the other 2 buttons on the left are scrambled.
I can move the mouse pointer and fish follows me, but clicking does
not produce anything. Sometimes the window appears full screen,
sometimes it takes only part of the screen. The original game (as
bought with the indie bundle) works perfectly fine. Here are the steps
I followed, I may have done something wrong:

1- hg clone http://hg.icculus.org/icculus/aquaria
2- cd aquaria
3- mkdir build
4- cd build
5- cmake ..
6- make -j 8
7- cp aquaria /path/to/where/I/installed/the/original/game/

Is it the right process?

My configuration:

Ubuntu linux 10.10 up to date
Laptop sony vaio vpc ea4s1e/b (http://preview.tinyurl.com/3eu9fcn)
Mobility Radeon HD 5000 Series with proprietary driver FGLRX

I tried with the open source radeon driver, but the game was too slow
(slow enough that I killed it before it even had a chance to display
the menu, it was like 20 seconds to display the BitBlot logo)

Can I do anything to help you help me?

Thank you for your work

Damien Cassou

"Lambdas are relegated to relative obscurity until Java makes them
popular by not having them." James Iry

More information about the aquaria mailing list