[aquaria] Windows compilation help

KTP kermitpumpkin at gmail.com
Sat Jun 19 22:25:25 EDT 2010

Ok, I added MSYS and tried that command and it didn't work out.  I'm going
to retry setting up MSYS, because I'm not certain I did it right the first

I did get it to compile with MinGW alone.  I checked the PATH variable, and
it did not have any paths to OpenAL or SDL sdk directories, so I added
those.  When I ran cmake gui again, it detected those things without
requiring me to enter them, so I was probably manually setting one of those
incorrectly before.  Then I used "mingw32-make" to compile.  It produced
aquaria.exe.  I dropped it into my aquaria directory, but it does not run.
 Produces error message that says "The application was unable to start
correctly."  Also the executable is 41meg compared to the released game's
2meg file size.  Does the build process default to a debug build?

Any insights that anyone can offer are appreciated.

Thank you to everyone who has humored this noob so far.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://icculus.org/pipermail/aquaria/attachments/20100619/97ae2a1d/attachment.htm>

More information about the aquaria mailing list