[aquaria] Errors when compiling FreeType2 with Visual C++ 2010

Joël Fivat joelfivat at hotmail.com
Fri Jun 11 15:47:30 EDT 2010


I installed CMake and created the project files for the Visual C++ 2010.

I try to compile Aquaria, but I am facing a wall of different errors. I have been able to solve some, like :

- INPUT_MOUSE and INPUT_KEYBOARD already defined (where ???)

-> undef them in DSQ.h

- resx, resy not declared (???)

-> declare them in DSQ.h

int resx;
int resy;

OpenGL functions in OpenGLStubs.h already defined :
Comment everything ?

Strange errors with FTTextureGlyph :
Comment everything and pray it is not used ? Aww I feel this won't work.

And now it is compiling further, I have errors with FreeType2. It says it can not open <ft2build.h>.

Well, ok so I add the path : C:\Program Files\AquariaDEV\BBGE\freetype2\include so he finds the file. But when I compile, I get tons of ft2 errors. I don't know how to solve this. Tried an other version of ft2, still get the same errors. Anyone had the same problem ?

Sorry, the last time I did used C++, it was like 10 years ago, so it is very difficult for me to know what to do. Should I use an other compiler ? I looked at Mingw32 but I don't want to try to go into something that looks so hard to install.

I really wanted to do some cool changes in Aquaria, but if compilation is a hell, I might just give up...

Thanks for reading :) (can anyone help me ?)

Hotmail: Powerful Free email with security by Microsoft.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://icculus.org/pipermail/aquaria/attachments/20100611/181fe2f6/attachment.htm>

More information about the aquaria mailing list