[aquaria] Sound issues with OpenAL

Mathieu Comandon strycore at gmail.com
Mon Dec 14 16:00:23 EST 2009

Hi Ryan and all Aquarius beta testers.

I tried the Aquaria beta, looks really good, but one severe bug is 
really keeping me from playing.
I'm not reporting this bug on the bug tracker because I'm not sure it's 
Aquaria's fault, I'm having problems with any OpenAL based game since 
I've been using Ubuntu Karmic 64Bit. The behavior changes depending on 
the game, for example Alien Arena won't even start.
In Aquaria's case, it starts ok except for small sound glitches from 
time to time, and then at some point (maybe 3 or 4 minutes of gameplay) 
, the sounds stops completely.
When this happens, i can't quit the game properly, I can go back to the 
main menu, try to quit but all I will get is a black screen. I have to 
go in a TTY, type killall -9 aquaria and then go back to my desktop.
Of course, there's the weird xrandr bug where I get all my 2960x1050 
desktop space on a 1680x1050 screen (which is the game's resolution). 
The xrandr tool thinks the resolution is correct so to fix this I've got 
to run "xrandr -s 1 && xrandr -s 0".
This wasn't the first time I tried to fix OpenAL issues, I tried 
compiling the latest libopenal, which was pretty useless since aquaria 
is a 32bit ELF and I'm 64bit. Then I tried to copy libopenal.so.1 from 
aquaria's directory to /usr/lib32. That didn't do much ...
I don't really know what to do next. I guess the corresponding bug in 
Launchpad regarding OpenAL would be this one  : 

What about other beta testers ? Do you experience such issues ? Is it 
also on Ubuntu 9.10 or are other distros being affected by this problem 
? I'm really looking forward to get this bug fixed because it would not 
only be awesome for Aquaria but also for a whole bunch of other games.


More information about the aquaria mailing list