[quake3-bugzilla] [Bug 6429] vm_x86.c inline assembly error on hosts using -fPIC

bugzilla-daemon at icculus.org bugzilla-daemon at icculus.org
Wed Jun 15 21:54:37 EDT 2016


--- Comment #12 from Mark <mark at noffle.net> ---
Gentoo hardened. 5.3.0 is masked and not considered stable yet so I'm hesistant
about installing it on that box.

I've tried gcc 4.9, 5.3 and 6.1 on a Ubuntu box and couldn't reproduce the
compiler error, appears to only occur on the Gentoo box which is leading me to
think that a Gentoo compiler patch might be to blame here. I'll be working on
testing that theory this week but it may take me a couple days.

Were you able to successfully test your push/pop ebx changes with a QVM? On
stock Ubuntu I'm seeing sigsegvs. As a workaround I've built the binary with
5.3.0 with necessary flags and merely scp'd it over which apparently worked,

You are receiving this mail because:
You are the QA Contact for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://icculus.org/pipermail/quake3-bugzilla/attachments/20160616/b85e09c8/attachment.html>

More information about the quake3-bugzilla mailing list