[quake2] quake2 vsync & q2max044.

Anders Storsveen wakko at generation.no
Tue Nov 15 13:34:38 EST 2005

Nelson Marques wrote:

> Use the 16bit pack, but in options make sure you have set it to use
> 8bit... read the docs, it's clearly there...
> nm
> philip murray wrote:
>> If the larger maxpack.pak is 16bit and the smaller one 8bit then i'll
>> stick to the 16bit one as it should be better i think. but for the
>> sake of tinkering i tried to load up q2 with 3.7mb maxpak.pak and
>> then switch to 8bit but it just gives a blank screen which i exit via
>> ctrl+c and this is left in the console:
>> "Using XFree86-VidModeExtension Version 2.2
>> I: got 8 bits of red
>> I: got 8 bits of blue
>> I: got 8 bits of green
>> I: got 24 bits of depth
>> I: got 0 bits of alpha
>> I: got 8 bits of stencil
>> Using hardware gamma
>> murray at zippy:/mnt/special/Games/fps/q2_files/q2_game/quake2_max$  "
>> if i just replace the 16bit maxpak.pak with the 8bit one it gives the
>> error:
>> "Error: Missing Particle Picture: particles/beam.jpg"
>> i cant find the config.cfg file for quake2max, the vanilla quake2 one
>> is in ~/.quake2/baseq2 easy enough, any idea where the q2max one
>> might be, or if there is a command-line entry to set 8 or 16bit. oh,
>> and i do have all three 8/16/24 depth modes available in xorg.conf.
>> But, i doubt getting q2maxpak sorted out will stop it from randomly
>> crashing, so i was really hoping someone might know what to do about
>> the panning flicker in q2non-max. or are there any other alternative
>> q2max-type engines available that work in linux?
>> Thanks,
>> Philip.
>> ----Original Message Follows----
>> From: Nelson Marques <nmarques at netvisao.pt>
>> Reply-To: quake2 at icculus.org
>> To: quake2 at icculus.org
>> Subject: Re: [quake2] quake2 vsync & q2max044.
>> Date: Tue, 15 Nov 2005 01:02:35 +0000
>> You need to set 8bit texture on I think to use that pack... read the
>> docs but I think that's the trick...
>> NM
>> philip murray wrote:
>>> Hi,
>>> I'm trying top get Q2 to work on my Slackware 10.2 box (i'm trying
>>> to get the whole q1-q4 series running, but q3 & q4 are *too* easy to
>>> install  :oP  ). I'm using the icculus quake2-v0.16.1.tar.gz file. i
>>> have followed the readme file & successfully got both the vanilla &
>>> q2Max versions working in separate directories. well mostly.
>>> the vanilla version suffers from annoying 'almost-flicker' when
>>> panning/strafing which would probably be solved by enabling vsync,
>>> but i cant find out how to do this. i just think this has always
>>> been an issue with q2. i cant find any command line to do this in
>>> the config.cfg, nor within the nvidia-setting program, googling also
>>> didnt get any answer.
>>> the q2max version went in fine also, although the maxpak.pak from
>>> the q2max-0.44 doesnt seem to work, it gives the blaster.jpeg
>>> missing error, i tried placing it both in the main baseq2 directory
>>> & /home/.quake2/baseq2 directory as suggested, but neither worked.
>>> but the one linked within the 0.16.1 readme file seems to work ok,
>>> and it is a bigger file (3.1mb vs 1.7mb). the q2max just seems a bit
>>> flakey & crashes out at various times, sometimes doing the retpeat
>>> terminal spew which needs a ctrl+c to kill.
>>> i'd like to just fix the vanilla q2 version, if any suggestions
>>> about the q2max version are forthcoming i could try them too as
>>> maybe q2max is the best way to escape the strafe flickering.
>>> here's the command i use to start it (both versions);
>>> LD_PRELOAD=libGL.so.1 ./quake2 +set vid_ref glx +set gl_driver
>>> libGL.so.1 +set _windowed_mouse 1
>>> Oh, and is there a mailing list archive as I'm probably asking
>>> simple questions that have been answered before (sorry if i am), but
>>> i cant find one on the icculus/q2 website, because i could traul it
>>> for answers too.
>>> Thanks,
>>> Philip.
the flicker problem COULD be lower fps or something, related to the
ati-drivers and vanilla q2 bug I've been talking about? are you using ati?

More information about the quake2 mailing list