quake2 vsync & q2max044.

philip murray philipihmurray at hotmail.com
Mon Nov 14 18:45:18 EST 2005


I'm trying top get Q2 to work on my Slackware 10.2 box (i'm trying to get 
the whole q1-q4 series running, but q3 & q4 are *too* easy to install  :oP  
). I'm using the icculus quake2-v0.16.1.tar.gz file. i have followed the 
readme file & successfully got both the vanilla & q2Max versions working in 
separate directories. well mostly.

the vanilla version suffers from annoying 'almost-flicker' when 
panning/strafing which would probably be solved by enabling vsync, but i 
cant find out how to do this. i just think this has always been an issue 
with q2. i cant find any command line to do this in the config.cfg, nor 
within the nvidia-setting program, googling also didnt get any answer.

the q2max version went in fine also, although the maxpak.pak from the 
q2max-0.44 doesnt seem to work, it gives the blaster.jpeg missing error, i 
tried placing it both in the main baseq2 directory & /home/.quake2/baseq2 
directory as suggested, but neither worked. but the one linked within the 
0.16.1 readme file seems to work ok, and it is a bigger file (3.1mb vs 
1.7mb). the q2max just seems a bit flakey & crashes out at various times, 
sometimes doing the retpeat terminal spew which needs a ctrl+c to kill.

i'd like to just fix the vanilla q2 version, if any suggestions about the 
q2max version are forthcoming i could try them too as maybe q2max is the 
best way to escape the strafe flickering.

here's the command i use to start it (both versions);

LD_PRELOAD=libGL.so.1 ./quake2 +set vid_ref glx +set gl_driver libGL.so.1 
+set _windowed_mouse 1

Oh, and is there a mailing list archive as I'm probably asking simple 
questions that have been answered before (sorry if i am), but i cant find 
one on the icculus/q2 website, because i could traul it for answers too.



More information about the quake2 mailing list