[quake2] To all the mouse problem peoples

Anders Storsveen wakko at generation.no
Sun Mar 20 09:04:27 EST 2005

I also noticed that by default I have mouse acc, when I enter X I have to  
do xset m 0 0, and "xset m" sets it to default, which is with mouseacc. In  
kdm I also have it. I tried another thing here, I started quake3 and then  
went to consoe and did "DISPLAY=:0 xset m 0 0" which definantly changed  
the mouse in quake3, I still had mouseacc but the mouse was faster.

On Sun, 20 Mar 2005 04:11:18 +0100, Anders Storsveen <wakko at generation.no>  

> common, I need to figure out what makes your mouse have no acc and my  
> mouse have? what interface does it use, and how do you configure that  
> interface?
> On Fri, 18 Mar 2005 22:10:26 +0100, Anders Storsveen  
> <wakko at generation.no> wrote:
>> On Fri, 18 Mar 2005 03:39:00 +0100, Anders Storsveen  
>> <wakko at generation.no> wrote:
>>> On Fri, 18 Mar 2005 03:15:41 +0100, Julien Langer <jlanger at zigweb.de>  
>>> wrote:
>>>>> I haven't seen an single computer where quake3 has had mouse  
>>>>> acceleration
>>>>> off (though this is not a problem, I'm pretty sure you have mouse
>>>>> acceleration). If you follow my description you will think so too.
>>>>> In the quake3 menu, first thing you see, move the mouse to the var  
>>>>> left or
>>>>> right. then mark off a little area (about 15cm) by putting an  
>>>>> obstacle on
>>>>> each side (some books there or something). move the mouse slowly to  
>>>>> the
>>>>> other obstacle (use about 15 seconds or more), then mark off how  
>>>>> much the
>>>>> mouse moved on the screen (mine moved to the middle of the screen.  
>>>>> THEN
>>>>> move it back to where you started (don't move the obstacles) then  
>>>>> move the
>>>>> mouse quickly to the other obstacle, like under one second. Then my  
>>>>> mouse
>>>>> was stopped on the other side of the screen. THIS means that you have
>>>>> mouse acceleration.
>>>>> Also I have done "xset m 0 0" and set mouse acceleration to x1.0 in  
>>>>> kde
>>>>> setup.
>>>> Ok...
>>>> I placed two books on my mouse pad in the exact distance to be able to
>>>> do a 360° turn in the game. (I couldn't try this in the q3 menu since
>>>> the mouse speed in the menu is so high that the cursor moves from one
>>>> border to the other by just moving the mouse 1 cm on the pad)
>>> the fact that you have very high sens in the quake3 menu may be an  
>>> indication that you infact don't have mouse acceleration!
>>> do you have dgamouse enabled? Please PLEASE tell me all your settings  
>>> specs, please post your xorg.conf and every setting you can think of :)
>> just bumping this suggestion that the fact that you have high sens  
>> would indicate no mouse acc, I believe its the same in some windows  
>> games, when you get mouseacc off in cs the sens is very high!
>> why oh why!
>>>> I moved the mouse veeery slow from the first book to the second and It
>>>> did a complete 360° turn.
>>>> I moved the mouse back to the other book very fast, and again did a  
>>>> 360°
>>>> turn.
>>>> I tried this 20 or 30 times, moving the mouse slowly from one book to
>>>> the other, and moving it fast. And it really did always a 360° turn.  
>>>> Not
>>>> more and not less. (except when I accidentally pushed the books a few
>>>> millimetres with the mouse ;))
>>>> And I know how mouse acceleration "feels". I played quake3 with  
>>>> in-game
>>>> mouse acceleration for quite some time.
>>>> So I really can't see any acceleration there.
>>>> Oh and the mouse is always exactly the same, no matter what I have set
>>>> up with xset. Quake 3 (and other games) accesses the mouse directly.
>>>> Maybe you should try to enable DGA in your Xserver?
>>> I need to have this enabled to get xrandr to work, this disables  
>>> dga-mouse too right?
>>>      SubSection  "extmod"
>>>          Option  "omit xfree86-dga"
>>>      EndSubSection
>>>> Regards,
>>>> Julien

Anders Storsveen
The Next Generation

More information about the quake2 mailing list