[quake2] Release 0.16

Fabrice Colin fabrice.colin at ntlworld.com
Mon Jan 3 09:19:44 EST 2005


On Sa, 2005-01-01 at 23:19 -0500, Brendan Burns wrote:
   > Hey folks,
   > I've posted an official release 0.16 on the web-site.  I think alsa
   > sound is working and all mouse bugs are fixed.  I tried connecting to
   > a multi-player game and mouse worked fine, including inversion...
   > Please try it out and let me know if problems persist.

I tried to build the source on Fedora Core 3 with ALSA support turned on
and had to make a couple of changes to src/linux/snd_alsa.c to get the
source to compile.
The errors centered on snd_pcm_hw_params_get_buffer_size(). FC3 comes
with ALSA 1.0.6. I have attached a patch.

I hope this helps.


-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: quake2_r0_16_1-snd_alsa_c.patch
URL: <http://icculus.org/pipermail/quake2/attachments/20050103/2cec5968/attachment.diff>

More information about the quake2 mailing list