ALSA implementation causes soundstuttering? :/

Paul Klumpp haudraufwienix at
Wed Aug 31 18:04:48 EDT 2005

I haven't got icculus' q2 ALSA to work correctly. It's stuttering the
whole time and thus slows down the graphics too. I tried many things
like changing snddevice to plug:hw or default, etc. (of course I haven't
forgot snd_restart)

Perhaps someone can reproduce that.
I'm using gentoo's kernel 2.6.11 and ALSA 1.0.9b as modules. (emu10k1
sound chipset)

When "Maniac-" (coder of the AprQ2 project:
tried to import the ALSA code, we had the same problems with his client
then. We even tried the quake2forge's ALSA implementation, but had the
exact same soundstuttering. So I told Maniac to use the ALSA code of
EzQuake since I had no problems with it. And there, it worked just fine.
Maniac hasn't released the fixed ALSA stuff yet. But...

Please take a look at EzQuake's ALSA implementation.

I wrote a howto to which I point many people often.. and I got to know
of these problems the day someone tried to install icculus' q2 - and he
wanted to play with ALSA.
The url is:
Paul Klumpp
paul at

More information about the quake2 mailing list