[quake2] Turkey Day...

Brendan Burns brendanburns at comcast.net
Mon Nov 29 15:12:58 EST 2004

that's a seg-fault...

What do the contents of your baseq2 directory look like?  (do an "ls 

can you try running it in GDB?

e.g. "gdb quake2"
"run +set vid_ref softx"

and when it crashes type "where" to get the line number...

Do you have compilers installed?  Could you try release 0.16 
(http://www.icculus.org/quake2/files/quake2-r0.16.tar.gz) and see if 
you have the same problem.


On Nov 29, 2004, at 1:21 PM, MiDiaN wrote:

> Hmm... looks better, I got this error msg now:
> Received signal 11, exiting...
> Ive tried to run on root too, thought it was the 3D drivers that 
> needed root
> permission to run... =(
> On Monday 29 November 2004 20:05, brendanburns at comcast.net wrote:
>> Do the other renderers work?  e.g.
>> quake2 +set vid_ref softx
>> or
>> quake2 +set vid_ref glx
>> --brendan
>>> Oh im so sorry, forgot the topic heh...
>>> well the errormsg is:
>>> Fatal signal: Segmentation Fault (SDL Parachute Deployed)
>>> and there is no other error msg's...
>>> yeah i tried to load a map too but the same error... Its strange I 
>>> can
>>> view the demo in the beginning in the game.... but when i try to 
>>> play all
>>> shuts down... =(
>>> On Monday 29 November 2004 16:34, Thomas J Fogal wrote:
>>>>  <200411291320.34956.midian at saunalahti.fi>MiDiaN writes:
>>>>> I just installed the Quake2 RPMS with no Mission-pack support
>>>>> (http://www.chez.com/colinf/quake2/CD/quake2-r0.15-io1.i386.rpm) 
>>>>> and
>>>>> the Q2max pak file, and the game starts up with no errors and GL
>>>>> graphics... but when i try to make a game (Single player, trying to
>>>>> play a map) the game shuts down and the error comes up (Subject
>>>>> topic), there is no other errors
>>>> you get an error that says "Turkey Day..." ?
>>>>> displayed than that...
>>>> instead of navigating through the menu, could you try loading up
>>>> quake2, bringing up the console (default key: tilde), and using 'map
>>>> base1'. Does that crash as well?
>>>> What exactly is the error message you are receiving?
>>>>> I got Linux Mandrake 10.0 with reinstalled 1.2 SDL and NVIDIA 
>>>>> GF2MX,
>>>>> the game works, but I cant play it =) Can it be missing files? Or 
>>>>> is
>>>>> it the SDL that is wrong configured?
>>>> I'm not sure. We'll need more information about the error message.
>>>> You might want to try the 0.14 RPM that is posted on that same 
>>>> webpage.
>>>> It sounded like the 0.15 one was untested. Of course, my personal
>>>> recommendation is to always use the source...
>>>>> (sry if I had bad english, Im from Finland)
>>>> Thats okay, don't worry about it.
>>>> -tom

More information about the quake2 mailing list