[quake2] floating point exception

arny at taiga.com arny at taiga.com
Sat Jun 26 23:07:02 EDT 2004


OK, so who is actually on this list, is there any way of
telling?  Or even better is there any way of reading old

I still wouldn't mind getting this working on my system.
Can anyone give me any comments, for instance details of
their x86 linux systems they've managed to get quake2-r0.15
working on?  (amount of ram, compiler version, kernel version,
version of libraries, type of processor, graphics card, etc).

Anyone had it working on a 2.4.x kernel?  I tried upgrading
to linux 2.4.26 and that didn't fix it.

Has anyone had it working on slackware?  If so what release?
(cat /etc/slackware-version).

As been as the problem is about at the time it starts processing
the game data, has anyone had quake2-r0.15 working with the
'demo' data installed exactly like the readme says?  I have the
full CD, but I pressume theres different versions.

I'm an experienced unix C coder (no graphics, C++ or x86 asm
experience though), anyone suggest a source file I could start
putting a few printf()s in to try and narrow the problem

Anyone any other ideas?  I really don't want to use a
precompiled binary.


Robin Arnold - arny at taiga.com

> Hello,
> I can seem to find any FAQs or mailing list archives mentioned
> on the icculus site so I'm asking this list...
> I've compiled quake2-r0.15 fine and followed the installation
> instructions carefully.  However when I start quake2 or sdlquake2
> they both quit out on a floating point exception as soon just
> after you start a game and get the 'loading' graphic on the black
> screen.  Its just after the music on the CD starts up, but before
> you see any of the game.  The introductory video plays OK and
> if I hit space just after starting the game, the option menus work
> fine.  I've tried it using svgalib and X, with both quake2 and
> sdlquake2 and get the same problem.  I've also tried it with both
> the full CD data and the demo download data, exactly as described
> in the readme in the quake2-r0.15 tar, same problem with both.
> I'm using linux 2.4.20 on a system installed from Slackware 8.1
> - not too old, not too new.  libSDL-1.2.so.0.0.4 is the SDL libary
> on my system.  System is an AMD XP2200 with 512 meg of ram with a
> PCI voodoo 4 3dfx video card (32 meg of ram I think), 200 gig of
> disk space using 2 IDE drives.  I've got all the libraries needed
> for the hardware 3d rendering for flight gear installed and working
> (glide, glut etc), but I'm just trying to get quake2 working with
> software rendering under svgalib first.
> ------- sound initialization -------
> sound sampling rate: 11025
> ------------------------------------
> ------- Server Initialization -------
> 0 entities inhibited
> 0 teams with 0 entities
> -------------------------------------
> Changing map...
> reconnecting...
> Installation
> svgalib: Signal 8: Floating point exception received.
> Floating point exception
> is what I see.
> Thanks,
> Robin Arnold

More information about the quake2 mailing list