floating point exception

arny at taiga.com arny at taiga.com
Mon Jun 21 18:50:27 EDT 2004


I can seem to find any FAQs or mailing list archives mentioned
on the icculus site so I'm asking this list...

I've compiled quake2-r0.15 fine and followed the installation
instructions carefully.  However when I start quake2 or sdlquake2
they both quit out on a floating point exception as soon just
after you start a game and get the 'loading' graphic on the black
screen.  Its just after the music on the CD starts up, but before
you see any of the game.  The introductory video plays OK and
if I hit space just after starting the game, the option menus work
fine.  I've tried it using svgalib and X, with both quake2 and
sdlquake2 and get the same problem.  I've also tried it with both
the full CD data and the demo download data, exactly as described
in the readme in the quake2-r0.15 tar, same problem with both.

I'm using linux 2.4.20 on a system installed from Slackware 8.1
- not too old, not too new.  libSDL-1.2.so.0.0.4 is the SDL libary
on my system.  System is an AMD XP2200 with 512 meg of ram with a
PCI voodoo 4 3dfx video card (32 meg of ram I think), 200 gig of
disk space using 2 IDE drives.  I've got all the libraries needed
for the hardware 3d rendering for flight gear installed and working
(glide, glut etc), but I'm just trying to get quake2 working with
software rendering under svgalib first.

------- sound initialization -------
sound sampling rate: 11025
------- Server Initialization -------
0 entities inhibited
0 teams with 0 entities

Changing map...

svgalib: Signal 8: Floating point exception received.
Floating point exception

is what I see.


Robin Arnold

More information about the quake2 mailing list