Mouse issues with GLX renderer

Joshua Barney derewuff at
Fri Jan 16 12:38:42 EST 2004

The GLX renderer has always worked well for me in the past, but when
I switched over to Gentoo and tried to compile the latest CVS, the
mouse in GLX mode is pretty much unusable.  It still works... sorta. 
Moving the (USB Logitech) mouse around only results in sporadic,
miniscule motion, with an occasional large jump.  It's as if the game
were only receiving intermittent signals from my mouse, sometimes for
only a split second, resulting in a small motion, and sometimes for a
second or two, resulting in a larger motion.

Funnily enough, when I switch over to the SDLGL renderer, the mouse
is just fine.  However, the SDLGL renderer performs noticeably poorer
than its GLX counterpart, with framerate differences averaging at
30fps.  GLX pushes the framerates all the way to the cl_maxfps limit,
but SDLGL wallows down around 60 with nothing going on, going down to
30 or below in an intense firefight.  So yeah, I want to use GLX
instead, except the damn mouse...

No other game on my machine experiences this problem.  I'm a bit
clueless as to where exactly to start diagnosing this so I can fix
it.  I was hoping some of you would know.  Y'know?

Oh, and a little side note. seems to be dead. 
Anyone know where I can fetch the latest texturepacks?  Karen?  =)

Many thanks.

~ Joshua

"You can't have bread and loaf."

Do you Yahoo!?
Yahoo! Hotjobs: Enter the "Signing Bonus" Sweepstakes

More information about the quake2 mailing list