[openbox] Key Chains mixing XF86* and other keys

Jan Harders jan at delinquent.de
Mon May 5 18:44:15 EDT 2014

Am 05.05.2014 21:08, schrieb Dana Jansens:>    but it does not work as
intended, the action is not run. If I hit
>     XF86Tools and wait a second, the little Key Chain dialogue appears
as it
>     should. Hitting F7 (or any other non-XF86*-key) ends the Key Chain
>     without executing the action.
> Try running xev, and then hitting XF86Tools and see what keycode F7 is
> generating afterward. Maybe the keyboard sends something different based
> on that key being pressed or something weird.

I tried that, there's no difference in xev's Output.
I've helped myself by using a small perl-script that I run when
XF86Tools is pressed (and close if it's pressed again, since wxperl
doesn't capture XF86Tools). It work like I wanted it, so I'm good in
general, allthough I'd still like to have the clean solution -- so if
there are any theorys around ...



More information about the openbox mailing list