trouble compiling

Tomasek, Kevin ktomasek at
Wed Nov 26 16:44:22 EST 2008

trying to compile openbox  i get the following message:
checking pkg-config is at least version 0.9.0... yes
checking for GLIB... configure: error: Package requirements (glib-2.0 >=
2.6.0) were not met:
Requested 'glib-2.0 >= 2.6.0' but version of GLib is 2.4.7
Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.
Alternatively, you may set the environment variables GLIB_CFLAGS
and GLIB_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
ktomasek at d2al220 <mailto:ktomasek at d2al220>
/tmp/openbox-[39]>which pkg-config
ktomasek at d2al220 <mailto:ktomasek at d2al220>  /tmp/openbox-[40]>eg
ktomasek at d2al220 <mailto:ktomasek at d2al220>
/tmp/openbox-[41]>uname -a
Linux d2al220 2.6.9-34.0.2.ELsmp #1 SMP Fri Jul 7 18:22:55 CDT 2006
x86_64 x86_64 x86_64 GNU/Linux

from the results of uname, it seems that i am running a version of glib
which is greater than 2.6.  why is configure having a problem with
here is the configure command line:
./configure --prefix=/usr/local --libdir=/usr/lib64  
how is one to know what value GLIB_CFLAGS should be set to?
thanks.. kevin
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the openbox mailing list