Installing make

Mark Gjøl cyrax at
Thu Mar 18 07:12:17 EST 2004

I'm installing openpkg on a SUN ultraSPARC running Solaris 9.

I've bootstrapped the system with:
sh --prefix=/opt/openpkg/2.0/

Then I ran the eval script:
eval `/opt/openpkg/2.0/etc/rc --eval all env`

So all should be fine. Now... I thought it would probably be a good idea
to install gcc and make and such basic packages, so I ran:
openpkg rpm --define "use_cc /opt/sfw/gcc-3.2/bin/gcc" --define
"use_make /opt/sfw/bin/gmake" --rebuild

And this is where the story comes to a grinding halt... After a bunch of
configure lines I get:
config.status: executing default-1 commands
config.status: creating po/POTFILES
config.status: creating po/Makefile
+ /opt/sfw/bin/gmake --no-print-directory -j4
make  all-recursive
/bin/bash: make: command not found
gmake: *** [all] Error 127
error: Bad exit status from /opt/openpkg/2.0/RPM/TMP/rpm-tmp.5915

I know gmake is where I said it was. I've told openpkg to use that
gmake, but even if it chooses not to I have a handy SUN make located
cozilly in /usr/xpg4/bin/make... What's wrong?

// Mark Gjøl
I find the whole business of religion profoundly interesting. But it does mystify me that otherwise intelligent people take it seriously.
 - Douglas Adams

More information about the openbox mailing list